summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-05 22:30:43 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:49 +0000
commit796e8f1d6eafb6d650bcfef45743f5f9704a2131 (patch)
tree668920f05eabd64147b9e6a2eb39eb6532d2b613 /gnu/packages/golang-xyz.scm
parent68dafa0887c9949abdc0b43eedb923a20c0750c3 (diff)
gnu: go-github-com-charmbracelet-lipgloss: Remove examples.
* gnu/packages/golang-xyz.scm (go-github-com-charmbracelet-lipgloss) [arguments]<phases>: Add 'remove-examples. Change-Id: I4ea4f699df2eb9d1558ba5ac8f6247c5d92214e0
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 66bff24eb0..76bd712322 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1670,7 +1670,13 @@ tools.")
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/charmbracelet/lipgloss"))
+ #:import-path "github.com/charmbracelet/lipgloss"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples")))))))
(propagated-inputs
(list go-github-com-aymanbagabas-go-udiff
go-github-com-charmbracelet-x-ansi