summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-02 22:47:54 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:36 +0000
commit6d0f8af0f43cb501bd706f8dee9f83cb151bb1db (patch)
tree3f5ef6dd94e7a053312230a849aef134b4ec72e4 /gnu/packages/golang-xyz.scm
parent7685abec9eb69d64e9bd7005dc818673b8566dd4 (diff)
gnu: go-github-com-containerd-console: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-containerd-console): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ia6abf935788718ae023dd0395df26d417e7bf33c
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 22d587b29b..149b710583 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2673,6 +2673,32 @@ cgroup uses the OCI runtime-spec found
go-golang-org-x-sys
go-google-golang-org-protobuf))))
+(define-public go-github-com-containerd-console
+ (package
+ (name "go-github-com-containerd-console")
+ (version "1.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containerd/console")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1p10k6lwfxgij5a9i47dark8apffc6wn254dwj43ks8jr134854v"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/containerd/console"))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://github.com/containerd/console")
+ (synopsis "Console package for Go")
+ (description
+ "This is Golang package for dealing with consoles. It has few
+dependencies and a simple API.")
+ (license license:asl2.0)))
+
(define-public go-github-com-containerd-fifo
(package
(name "go-github-com-containerd-fifo")