summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-01-22 20:35:10 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-22 20:35:58 +0000
commit5666d8121231883a3cc601eb4889d3edf10dd6ca (patch)
treedf65834bfb110bc931a298ddd971d81fc8edeb9f /gnu/packages/golang-xyz.scm
parent2a9758e1c99422eef40a2ee2c35f6d3873cfa3fc (diff)
gnu: Add go-github-com-alecthomas-kong-hcl.
* gnu/packages/golang-xyz.scm (go-github-com-alecthomas-kong-hcl): New variable. Change-Id: Iea741ab1740eb0c956621ac6ed095a47014d3112
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm40
1 files changed, 39 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cd4b061c9f..a597fe4e3a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
-;;; Copyright © 2021, 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021, 2023-2025 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
@@ -860,6 +860,44 @@ be stripped.")
with as little developer effort as possible.")
(license license:expat)))
+(define-public go-github-com-alecthomas-kong-hcl
+ (package
+ (name "go-github-com-alecthomas-kong-hcl")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/kong-hcl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q383705kavn23ay4vzr662x9lsl2xc1mv5irhcy0cazjjc7jzp2"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Submodules with their own go.mod files and packaged separately:
+ ;;
+ ;; - github.com/alecthomas/kong-hcl/v2
+ (delete-file-recursively "v2")))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "-skip" "TestHCL/FromResolver")
+ #:import-path "github.com/alecthomas/kong-hcl"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-alecthomas-kong
+ go-github-com-hashicorp-hcl
+ go-github-com-pkg-errors))
+ (home-page "https://github.com/alecthomas/kong-hcl")
+ (synopsis "Kong configuration loader for HCL")
+ (description
+ "This package implements functionality to map HCL or JSON fragment into
+Golang structs.")
+ (license license:expat)))
+
(define-public go-github-com-alecthomas-participle-v2
(package
(name "go-github-com-alecthomas-participle-v2")