summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorAshvith Shetty <[email protected]>2025-02-15 00:35:32 +0530
committerSharlatan Hellseher <[email protected]>2025-02-15 16:08:40 +0000
commit4fcdaf8bcaf24fa3c37361e464ebecf1c6e64377 (patch)
tree6eb9954da96db77b0f077bdc6be2e4ffe2b27d4d /gnu/packages/golang-xyz.scm
parent57049ff631533decf5d1778c958972b51cfb8a45 (diff)
gnu: Add go-github-com-zyedidia-tcell-v2.
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-tcell-v2): New variable. Change-Id: Id6d92347e6b7b080b906f5ef7849b6589fb80d04 Co-authored-by: Sharlatan Hellseher <[email protected]> Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 3b9a6fcf4a..c1759b7ded 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -16129,6 +16129,37 @@ ongoing (blocked) read and write operations.
It's an active fork of @url{https://github.com/npat-efault/poller}.")
(license license:bsd-2)))
+(define-public go-github-com-zyedidia-tcell-v2
+ (hidden-package
+ (package
+ (inherit go-github-com-gdamore-tcell-v2)
+ (name "go-github-com-zyedidia-tcell-v2")
+ (version "2.0.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/tcell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rbivmy79sc8hnygj7b3axhiqgbx6xc4f28pz69nhq9w2skk3zb9"))))
+ (arguments
+ (list
+ #:import-path "github.com/zyedidia/tcell/v2"))
+ (propagated-inputs
+ (list go-github-com-gdamore-encoding
+ go-github-com-lucasb-eyer-go-colorful
+ go-github-com-mattn-go-runewidth
+ go-github-com-xo-terminfo
+ go-github-com-zyedidia-poller
+ go-golang-org-x-sys
+ go-golang-org-x-text))
+ (home-page "https://github.com/zyedidia/tcell")
+ (description
+ "It's an alternative fork of @url{https://github.com/gdamore/tcell}."))))
+
(define-public go-go-abhg-dev-komplete
(package
(name "go-go-abhg-dev-komplete")