summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-14 10:48:49 +0000
committerSharlatan Hellseher <[email protected]>2025-02-14 10:50:08 +0000
commit4b3cd1df99ea5076edc29d7d5725a4afbe5cf2ef (patch)
treea011b293af88e52d49f5f4e597975ca20700e57b /gnu/packages/golang-xyz.scm
parent4b5f0408e66392ab745dc0f7830732217d88f17d (diff)
gnu: go-github-com-go-md2man: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-go-md2man): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/containers.scm: Add (gnu packages golang-xyz). * gnu/packages/hardware.scm: Likewise. * gnu/packages/virtualization.scm: Likewise. Change-Id: I90bdb2a78887896bebf64eef7741d4c6d8e68b93
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2af3339197..3406d5f5d7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3519,6 +3519,32 @@ submodules:
"This package provides memcache client and server functionality.")
(license license:expat)))
+(define-public go-github-com-go-md2man
+ (package
+ (name "go-github-com-go-md2man")
+ (version "2.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cpuguy83/go-md2man")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gqlkv1pv8cpvcj8g77d1hzy5bnp5a3k3xs02iahlr3a65m4azsi"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/cpuguy83/go-md2man"))
+ (propagated-inputs
+ (list go-github-com-russross-blackfriday-v2))
+ (home-page "https://github.com/cpuguy83/go-md2man")
+ (synopsis "Convert markdown into roff")
+ (description
+ "Go-md2man is a Go program that converts markdown to roff for the purpose
+of building man pages.")
+ (license license:expat)))
+
(define-public go-github-com-creack-pty
(package
(name "go-github-com-creack-pty")