summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorAshvith Shetty <[email protected]>2025-02-15 00:35:25 +0530
committerSharlatan Hellseher <[email protected]>2025-02-15 15:42:22 +0000
commit499d3b81989e1eb2a09d5e0a97057e777462e12c (patch)
tree0654aaa34a9dca7965d10aaa21de958e19c136d2 /gnu/packages/golang-xyz.scm
parent05ab9bd7f36659ac3d116134891aca23da102144 (diff)
gnu: Add go-github-com-layeh-gopher-luar.
* gnu/packages/golang-xyz.scm (go-github-com-layeh-gopher-luar): New variable. Change-Id: Iafe2a8aa760d684dae485c12f639cdbdc8efc336 Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 3406d5f5d7..70c78808eb 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -56,6 +56,7 @@
;;; Copyright © 2024 Troy Figiel <[email protected]>
;;; Copyright © 2024 gemmaro <[email protected]>
;;; Copyright © 2024 Roman Scherer <[email protected]>
+;;; Copyright © 2025 Ashvith Shetty <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9593,6 +9594,31 @@ do not update the structure in-place, but instead always yield a new
structure. It's a stable fork of https://github.com/mndrix/ps.")
(license license:expat)))
+(define-public go-github-com-layeh-gopher-luar
+ (package
+ (name "go-github-com-layeh-gopher-luar")
+ (version "1.0.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/layeh/gopher-luar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zfafqy2jwjmrr0gl3h2ivn0iixb0bvslcwcly9bcmc5yxq35m89"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "layeh.com/gopher-luar"))
+ (propagated-inputs (list go-github-com-yuin-gopher-lua))
+ (home-page "https://github.com/layeh/gopher-luar")
+ (synopsis "Simplifies data passing to and from gopher-lua")
+ (description
+ "Package @code{gopher-luar} simplifies data passing to and from
+ @url{https://github.com/yuin/gopher-lua, gopher-lua}.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-leodido-go-urn
(package
(name "go-github-com-leodido-go-urn")