summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-11 12:53:00 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:56 +0000
commit3f1a4f4d85c94b4909f6fc07b6880a20a19dbb10 (patch)
tree3ce9fd6476392c6546f7c498a3d3d91395a9186c /gnu/packages/golang-xyz.scm
parente78ad292977692fd6b121faac706c530d2f9a6dc (diff)
gnu: go-github-com-michiwend-golang-pretty: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-michiwend-golang-pretty): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I851eb0caa396f84240579008b7b6c15cf906432c
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0dd99d1a55..f3eb6544c1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -10132,6 +10132,36 @@ language, namely support for record length-delimited message streaming.")
colored strings.")
(license license:expat)))
+(define-public go-github-com-michiwend-golang-pretty
+ (package
+ (name "go-github-com-michiwend-golang-pretty")
+ (version "0.0.0-20141116172505-8ac61812ea3f")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/michiwend/golang-pretty")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rjfms0csjqi91xnddzx3rcrcaikc7xc027617px3kdwdap80ir4"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:tests? #f ; Upstream tests seem to be broken.
+ #:import-path "github.com/michiwend/golang-pretty"))
+ (propagated-inputs
+ (list go-github-com-kr-text))
+ (home-page "https://github.com/michiwend/golang-pretty")
+ (synopsis "Pretty printing for Go values")
+ (description
+ "Package @code{pretty} provides pretty-printing for Go values. This is
+useful during debugging, to avoid wrapping long output lines in the terminal.
+
+It provides a function, @code{Formatter}, that can be used with any function
+that accepts a format string. It also provides convenience wrappers for
+functions in packages @code{fmt} and @code{log}.")
+ (license license:expat)))
+
(define-public go-github-com-miolini-datacounter
(package
(name "go-github-com-miolini-datacounter")