summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-01-11 16:44:56 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-21 23:47:59 +0000
commit3245ebe88c09b5f0aed5267a4b1ca3102dbe9790 (patch)
treec3568bd94faeb32dd23862fa2c493b57d2d7787b /gnu/packages/golang-xyz.scm
parent4feda720a163783ba8a2cef41c04f18fa7f87559 (diff)
gnu: Add go-github-com-txthinking-runnergroup.
* gnu/packages/golang-web.scm (go-github-com-txthinking-runnergroup): New variable. Change-Id: I305b21fcaba0cebdef5771370de43fe2b24c13a2
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 615bd48e45..fca6af6600 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -14332,6 +14332,31 @@ supported by the time package
(propagated-inputs
(list go-github-com-twpayne-go-vfs-v5))))
+(define-public go-github-com-txthinking-runnergroup
+ (package
+ (name "go-github-com-txthinking-runnergroup")
+ (version "0.0.0-20241229123329-7b873ad00768")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/txthinking/runnergroup")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l0accx6c880smkcma0qca3c67kx8p1bc4q2zq54iv8yjy1b2h4w"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/txthinking/runnergroup"))
+ (home-page "https://github.com/txthinking/runnergroup")
+ (synopsis "Golang standard @code{sync.WaitGroup} alternative")
+ (description
+ "This package implements a similar functionality like standard
+@code{sync.WaitGroup}}, the difference is if one task stops, all will be
+stopped.")
+ (license license:expat)))
+
(define-public go-github-com-urfave-cli
(package
(name "go-github-com-urfave-cli")