summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-25 12:30:10 +0000
committerSharlatan Hellseher <[email protected]>2025-01-25 12:34:00 +0000
commit193aac9a4d8f3f48b93c9e9f4abd11ff2ed38162 (patch)
tree0a6da92ef111ea158876909365d1ceb6ec88e33e /gnu/packages/golang-xyz.scm
parentade6e5c49ba0ea6c7b05ae7c81654e10961610c8 (diff)
gnu: Add go-toml.
* gnu/packages/golang-xyz.scm (go-toml): New variable. Change-Id: I7b766fa7b5e7ff33d3bbe84be4a65ec75e2d6303
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4cd014e627..d6456a814c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -17529,6 +17529,38 @@ tools."))))
"\nThis package provides an command line interface (CLI)
tool."))))
+(define-public go-toml
+ (package
+ (inherit go-github-com-pelletier-go-toml-v2)
+ (name "go-toml")
+ (arguments
+ (list
+ #:tests? #f ; tested in the library
+ #:install-source? #f
+ #:unpack-path "github.com/pelletier/go-toml"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'build
+ (lambda arguments
+ (for-each
+ (lambda (cmd)
+ (apply (assoc-ref %standard-phases 'build)
+ `(,@arguments #:import-path ,cmd)))
+ (list "github.com/pelletier/go-toml/cmd/tomljson"
+ "github.com/pelletier/go-toml/cmd/tomll"))))
+ (replace 'install
+ (lambda arguments
+ (for-each
+ (lambda (cmd)
+ (apply (assoc-ref %standard-phases 'install)
+ `(,@arguments #:import-path ,cmd)))
+ (list "github.com/pelletier/go-toml/cmd/tomljson"
+ "github.com/pelletier/go-toml/cmd/tomll")))))))
+ (description
+ (string-append (package-description go-github-com-pelletier-go-toml-v2)
+ "\nThis package provides command line interface (CLI)
+tools."))))
+
(define-public go-tomlv
(package
(inherit go-github-com-burntsushi-toml)