summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-29 22:11:28 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:38 +0000
commite863412e8bb4cd68ed7b82276726f1f21ee07d92 (patch)
treea3b9453a04f42ae0f9e43b0772ea1e4b7087694d /gnu/packages/golang-web.scm
parente74d247d0bd5d25b0af04de8d9fe01253682bc5b (diff)
gnu: go-github-com-dpotapov-go-spnego: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-dpotapov-go-spnego): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I4c4ab0aa707fe12f82a2393d763f6b5afc266f87
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 3d0fc3d8d2..5e55f82c87 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1396,6 +1396,36 @@ Data Representation (XDR) standard protocol as specified in RFC
4506 (obsoletes RFC 1832 and RFC 1014) in pure Go.")
(license license:isc)))
+(define-public go-github-com-dpotapov-go-spnego
+ (package
+ (name "go-github-com-dpotapov-go-spnego")
+ (version "0.0.0-20220426193508-b7f82e4507db")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dpotapov/go-spnego")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rpcgzkqhdwfsi8a9f9qar16i663pdx3gvwd6c0vfppy7qjmpjfr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/dpotapov/go-spnego"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-jcmturner-gokrb5-v8
+ go-golang-org-x-net))
+ (home-page "https://github.com/dpotapov/go-spnego")
+ (synopsis "HTTP calls with Kerberos authentication")
+ (description
+ "The package extends Go's HTTP Transport allowing Kerberos
+authentication through Negotiate mechanism (see
+@url{https://tools.ietf.org/html/rfc4559, RFC4559}).")
+ (license license:expat)))
+
(define-public go-github-com-elazarl-goproxy
(package
(name "go-github-com-elazarl-goproxy")