summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-16 03:40:27 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:04 +0000
commitd1365b4a6b2c3b8b0ea55e6b00cb8dd62551c321 (patch)
tree13fb43ef762e3b1d948e73d5b0460388fa624941 /gnu/packages/golang-web.scm
parentf1421f5ad4dfd8a24b676f8b85185ff83cf883d3 (diff)
gnu: Add go-k8s-io-kube-openapi.
* gnu/packages/golang-web.scm (go-k8s-io-kube-openapi): New variable. Change-Id: I66082515976053bbc888c9f2789df5dd78242d59
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm69
1 files changed, 69 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 132bb2bb1e..894060d4b3 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -6797,6 +6797,75 @@ Signing and Encryption set of standards. This includes support for JSON Web
Encryption, JSON Web Signature, and JSON Web Token standards.")
(license license:asl2.0)))
+(define-public go-k8s-io-kube-openapi
+ (package
+ (name "go-k8s-io-kube-openapi")
+ (version "0.0.0-20241212222426-2c72e554b1e7")
+ ;; XXX: Unbundle third_party in pkg.
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kubernetes/kube-openapi")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0crd349jd210bh68ic70pqmdkfns7cix2qhsa6pfya6kbvschyf9"))
+ ;; XXX: test/integration contains submodule with it's own go.mod.
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Keeping just testdata.
+ (for-each delete-file-recursively
+ (list "test/integration/builder"
+ "test/integration/builder3"
+ "test/integration/openapiconv"
+ "test/integration/pkg/generated"
+ "test/integration/testutil"
+ "test/integration/import.go"
+ "test/integration/integration_suite_test.go"))))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.23
+ #:import-path "k8s.io/kube-openapi"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'build)))) ; no go files in project's root
+ (native-inputs
+ (list go-github-com-getkin-kin-openapi
+ go-github-com-google-gofuzz
+ go-github-com-onsi-ginkgo-v2
+ go-github-com-onsi-gomega
+ go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-emicklei-go-restful-v3
+ go-github-com-go-openapi-jsonreference
+ go-github-com-go-openapi-swag
+ go-github-com-google-gnostic-models
+ go-github-com-google-go-cmp
+ go-github-com-google-uuid
+ go-github-com-munnerz-goautoneg
+ go-github-com-nytimes-gziphandler
+ go-github-com-spf13-pflag
+ go-golang-org-x-tools
+ go-google-golang-org-protobuf
+ go-gopkg-in-yaml-v3
+ go-k8s-io-gengo-v2
+ go-k8s-io-klog-v2
+ go-k8s-io-utils
+ go-sigs-k8s-io-json
+ go-sigs-k8s-io-structured-merge-diff-v4
+ go-sigs-k8s-io-yaml))
+ (home-page "https://github.com/kubernetes/kube-openapi")
+ (synopsis "Kubernetes OpenAPI spec generation & serving")
+ (description
+ "This package implements a Kubernetes OpenAPI discovery spec generation,
+providing support a subset of OpenAPI features to satisfy kubernetes use-cases
+but implement that subset with little to no assumption about the structure of
+the code or routes.")
+ (license license:asl2.0)))
+
(define-public go-mvdan-cc-xurls-v2
(package
(name "go-mvdan-cc-xurls-v2")