summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-11-06 11:42:27 +0200
committerEfraim Flashner <[email protected]>2024-11-06 12:49:39 +0200
commitacd36c81722bf1fdb83787919ae4e419530194b0 (patch)
tree1f9bfb6c5714586b98551afedb38cda5ed68fc62 /gnu/packages/golang-web.scm
parent9183e61ad14eb784e98afcd7494b9ed17a75ecaa (diff)
gnu: go-github-com-libp2p-go-cidranger: Disable tests when cross-compiling.
* gnu/packages/golang-web.scm (go-github-com-libp2p-go-cidranger) [arguments]: Also disable the tests when cross-compiling. Change-Id: I26df125d5a006ec9a4207a8e692eea38f7c48f1f
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index dcbc37cea3..2c3e8e41c3 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2020 Oleg Pykhalov <[email protected]>
;;; Copyright © 2020 Ryan Prior <[email protected]>
;;; Copyright © 2020 raingloom <[email protected]>
-;;; Copyright © 2020-2023 Efraim Flashner <[email protected]>
+;;; Copyright © 2020-2024 Efraim Flashner <[email protected]>
;;; Copyright © 2021 Collin J. Doering <[email protected]>
;;; Copyright © 2021 Philip McGrath <[email protected]>
;;; Copyright © 2021 Raghav Gururajan <[email protected]>
@@ -2808,7 +2808,8 @@ router.")
;; src/github.com/libp2p/go-cidranger/trie_test.go:557:8: cannot use
;; 4294967295 (untyped int constant) as int value in assignment
;; (overflows).
- #:tests? (target-64bit?)
+ #:tests? (and (target-64bit?)
+ (not (%current-target-system)))
#:import-path "github.com/libp2p/go-cidranger"))
(native-inputs
(list go-github-com-stretchr-testify))