summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2023-11-29 22:35:12 +0000
committerMaxim Cournoyer <[email protected]>2024-01-03 16:35:19 -0500
commit9b7806717f4ab244ba0cc4ec23dd4a841cbd910b (patch)
tree4d75484270dad18acbca1076297b481a90052dd3 /gnu/packages/golang-web.scm
parent61b29e1cf2a2093ae5f4a14685bdc993552ff041 (diff)
gnu: go-github-com-go-chi-chi-v5: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-go-chi-chi-v5): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I120c2cb142935430443a7e6c9e53aa8544bbaf8e
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 25 insertions, 2 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index f59415452f..2570be62f7 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1,17 +1,17 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Pierre-Antoine Rouby <[email protected]>
;;; Copyright © 2020 Martin Becze <[email protected]>
-;;; Copyright © 2020 Martin Becze <[email protected]>
;;; Copyright © 2020 Oleg Pykhalov <[email protected]>
;;; Copyright © 2020 Ryan Prior <[email protected]>
;;; Copyright © 2021 Sarah Morgensen <[email protected]>
;;; Copyright © 2021, 2022 Efraim Flashner <[email protected]>
;;; Copyright © 2022 Giacomo Leidi <[email protected]>
+;;; Copyright © 2022 Sharlatan Hellseher <[email protected]>
+;;; Copyright © 2022 jgart via Guix-patches via <[email protected]>
;;; Copyright © 2022 muradm <[email protected]>
;;; Copyright © 2023 Hilton Chain <[email protected]>
;;; Copyright © 2023 Katherine Cox-Buday <[email protected]>
;;; Copyright © 2023 Nicolas Graves <[email protected]>
-;;; Copyright © 2022 Sharlatan Hellseher <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -284,6 +284,29 @@ metrics (i.e. response time, bytes written, and http status code) from your
application's http.Handlers.")
(license license:expat)))
+(define-public go-github-com-go-chi-chi-v5
+ (package
+ (name "go-github-com-go-chi-chi-v5")
+ (version "5.0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-chi/chi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rzrsxz4xj0973c6nxklvq2vmg2m795snhk25836i0gnd1jnx79k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/go-chi/chi/v5"))
+ (home-page "https://github.com/go-chi/chi")
+ (synopsis "Composable router for HTTP services written in Go")
+ (description
+ "@code{go-github-com-go-chi-chi-v5} is an HTTP router that lets the user
+decompose request handling into many smaller layers.")
+ (license license:expat)))
+
(define-public go-github-com-google-safehtml
(package
(name "go-github-com-google-safehtml")