summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-15 20:55:51 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:03 +0000
commit62a9bb7f193659f8e278fb3d1fbeaa8a3662743f (patch)
tree24cfdfaf2d72daf95dfe9af92c5b92c81aa7253e /gnu/packages/golang-web.scm
parent73a2842c2b9b70345c0c257e8b59b849ed8c9780 (diff)
gnu: go-github-com-mailru-easyjson: Update to 0.9.0.
* gnu/packages/golang-web.scm (go-github-com-mailru-easyjson): Update to 0.9.0. [arguments]<phases>: Add 'remove-benchmarks. Change-Id: I5c0c450b32cae793a89c69e787de0dcb1b812c1a
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 6c9a5b0a0c..41c44a7d95 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -3653,7 +3653,7 @@ intends to be compatible with Avahi.")
(define-public go-github-com-mailru-easyjson
(package
(name "go-github-com-mailru-easyjson")
- (version "0.7.7")
+ (version "0.9.0")
(source
(origin
(method git-fetch)
@@ -3662,11 +3662,19 @@ intends to be compatible with Avahi.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0clifkvvy8f45rv3cdyv58dglzagyvfcqb63wl6rij30c5j2pzc1"))))
+ (base32 "00if9lpfy7bz853snqp7zgg76pn4mgpkk42h0riahcwk5v19jrcv"))))
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/mailru/easyjson"))
+ #:import-path "github.com/mailru/easyjson"
+ ;; XXX: All tests in "tests" directory fail, figure out why.
+ #:test-subdirs #~(list ".")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-benchmarks
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (delete-file-recursively "benchmark")))))))
(propagated-inputs
(list go-github-com-josharian-intern))
(home-page "https://github.com/mailru/easyjson")