summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-16 03:40:27 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:04 +0000
commit3be6f53285086d8aad9043d747dc845737387ffe (patch)
treec455e4fddd12ef996401a8f36a6fb868f75b36e2 /gnu/packages/golang-web.scm
parentbb2273cf91d8c6f98d7c63d812fb89bb409f9e1f (diff)
gnu: Add go-github-com-perimeterx-marshmallow.
* gnu/packages/golang-web.scm (go-github-com-perimeterx-marshmallow): New variable. Change-Id: I8d46a3e9469ed0518736e26f9c45a8f3f763ada8
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c9380977a3..7434c3e204 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -4472,6 +4472,37 @@ higher-level API for doing so.")
"Common enterprise features for the Go programming language.")
(license license:cc0)))
+(define-public go-github-com-perimeterx-marshmallow
+ (package
+ (name "go-github-com-perimeterx-marshmallow")
+ (version "1.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PerimeterX/marshmallow")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jxpjfyshcbrmj9qmj3sr21va6kw7hs55w2gaz9118jd861s6mbw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/perimeterx/marshmallow"))
+ (native-inputs
+ (list go-github-com-go-test-deep))
+ (propagated-inputs
+ (list go-github-com-mailru-easyjson
+ go-github-com-ugorji-go-codec))
+ (home-page "https://github.com/perimeterx/marshmallow")
+ (synopsis "JSON unmarshalling in Golang")
+ (description
+ "This package provides a simple API to perform JSON unmarshalling.
+It supports unmarshalling of some known and some unknown fields with zero
+performance overhead. While unmarshalling, it allows fully retaining the
+original data and access it via a typed struct and a dynamic map.")
+ (license license:expat)))
+
(define-public go-github-com-pion-datachannel
(package
(name "go-github-com-pion-datachannel")