summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-03 09:24:36 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:48 +0000
commit26310a2e11ffbc577abb395404e9a13e4c884afc (patch)
tree23c3ce86aa0ab96d5c218b8a008df0eb3bbaaa78 /gnu/packages/golang-web.scm
parenta2682b84442a1c32fbdbd369258364d1ed3a650c (diff)
gnu: go-github-com-vishvananda-netlink: Move to golang-web.
* gnu/packages/linux.scm (go-github-com-vishvananda-netlink): Move from here ... * gnu/packages/golang-web.scm: ... to here. * gnu/packages/docker.scm: Add golang-web module. Change-Id: I67bc7128e6ede1c717aefc089dbe3776dd885e40
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index a445f0d3c4..e10d07a57a 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2017, 2019, 2020, 2021 Leo Famulari <[email protected]>
;;; Copyright © 2018 Pierre Neidhardt <[email protected]>
;;; Copyright © 2018 Pierre-Antoine Rouby <[email protected]>
+;;; Copyright © 2019 Maxim Cournoyer <[email protected]>
;;; Copyright © 2019 Vagrant Cascadian <[email protected]>
;;; Copyright © 2019, 2020 Martin Becze <[email protected]>
;;; Copyright © 2020 Jack Hill <[email protected]>
@@ -5872,6 +5873,42 @@ encoding library for the MessagePack, CBOR, JSON and the Binc formats.")
replacement for native @code{net/http} module.")
(license license:expat)))
+(define-public go-github-com-vishvananda-netlink
+ (package
+ (name "go-github-com-vishvananda-netlink")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vishvananda/netlink")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ckwb1ml7i2ccdd7kzc04s839naf4arlxav2ip5kf4rm4xhba9g7"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; The tests are unsupported on all architectures except x86_64-linux:
+ ;; cannot use 0xabcdef99 (untyped int constant 2882400153) as int value
+ ;; in struct literal (overflows)
+ #:tests? (and (not (%current-target-system)) (target-x86-64?))
+ #:test-flags
+ ;; One test fails with error: operation not permitted.
+ #~(list "-skip" "TestSocketXDPGetInfo")
+ #:import-path "github.com/vishvananda/netlink"))
+ (propagated-inputs
+ (list go-github-com-vishvananda-netns
+ go-golang-org-x-sys))
+ (home-page "https://github.com/vishvananda/netlink")
+ (synopsis "Simple netlink library for Go")
+ (description
+ "The netlink package provides a simple netlink library for Go. Netlink
+is the interface a user-space program in Linux uses to communicate with the
+kernel. It can be used to add and remove interfaces, set IP addresses and
+routes, and configure IPsec.")
+ (license license:asl2.0)))
+
(define-public go-github-com-whyrusleeping-cbor
(package
(name "go-github-com-whyrusleeping-cbor")