summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-vcs.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-21 23:44:09 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:13 +0000
commit5f6cc183a226e81366c8ba317d3fd74e5ccf403f (patch)
treea90705814b9163079eaf259a27f6ec59b27bd8c2 /gnu/packages/golang-vcs.scm
parent3464b38a75687f5c4631804cd8e0aec6583958c4 (diff)
gnu: go-github-com-go-git-gcfg: Move to golang-vcs.
* gnu/packages/golang.scm (go-github-com-go-git-gcfg): Move from here ... * gnu/packages/golang-vcs.scm: ... to here. Add goalng-xyz module. Change-Id: I218c5e5c663ea5ba54cef9f26fec95912bbcac34
Diffstat (limited to 'gnu/packages/golang-vcs.scm')
-rw-r--r--gnu/packages/golang-vcs.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/golang-vcs.scm b/gnu/packages/golang-vcs.scm
index b264b3ecaf..967b5ea93d 100644
--- a/gnu/packages/golang-vcs.scm
+++ b/gnu/packages/golang-vcs.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Oleg Pykhalov <[email protected]>
;;; Copyright © 2024 Sharlatan Hellseher <[email protected]>
;;;
;;; This file is part of GNU Guix.
@@ -25,7 +26,8 @@
#:use-module (gnu packages)
#:use-module (gnu packages golang-build)
#:use-module (gnu packages golang-check)
- #:use-module (gnu packages golang-web))
+ #:use-module (gnu packages golang-web)
+ #:use-module (gnu packages golang-xyz))
;;; Commentary:
;;;
@@ -37,6 +39,34 @@
;;; Libraries:
;;;
+(define-public go-github-com-go-git-gcfg
+ (package
+ (name "go-github-com-go-git-gcfg")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-git/gcfg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lb14z4j35pwz2b2rbykkpsq515spwbndb00gwn2xlrzn949xb83"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/go-git/gcfg"
+ ;; pass; got 10, error <nil>
+ ;; failed to parse "a" as int: expected integer; *ptr==0
+ #:test-flags #~(list "-skip" "TestParseInt|TestScanFully")))
+ (propagated-inputs
+ (list go-github-com-pkg-errors
+ go-gopkg-in-warnings-v0))
+ (home-page "https://github.com/go-git/gcfg")
+ (synopsis "Gcfg reads INI-style configuration files into Go structs")
+ (description "Gcfg reads INI-style configuration files into Go structs.")
+ (license license:bsd-3)))
+
(define-public go-github-com-xanzy-go-gitlab
(package
(name "go-github-com-xanzy-go-gitlab")