summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-compression.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-02 22:34:11 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:36 +0000
commit9da289ce201fd8213f571a6df7a877ebab4f603c (patch)
treedfe5a5ea3714bd927a17995cf59dda693e82cb70 /gnu/packages/golang-compression.scm
parent07de0c94c1109142208096742ae01b5d8059e422 (diff)
gnu: go-github-com-klauspost-compress: Update to 1.17.11.
* gnu/packages/golang-compression.scm (go-github-com-klauspost-compress): Update to 1.17.11. [arguments] <phases>: Remove 'fix-permissions. [propagated-inputs]: Remove go-github-com-golang-snappy. Change-Id: I65fc1e856fdd7b961e497a1538d5d0d242bcaedb
Diffstat (limited to 'gnu/packages/golang-compression.scm')
-rw-r--r--gnu/packages/golang-compression.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index bdb9624c88..ab32f28dc8 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -166,7 +166,7 @@ library included in the stdlib, and supports GIF, TIFF and PDF.")
(define-public go-github-com-klauspost-compress
(package
(name "go-github-com-klauspost-compress")
- (version "1.13.1")
+ (version "1.17.11")
(source
(origin
(method git-fetch)
@@ -175,20 +175,11 @@ library included in the stdlib, and supports GIF, TIFF and PDF.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0ydnf9rizlhm8rilh14674qqx272sbwbkjx06xn9pqvy6mmn2r3r"))))
+ (base32 "1i8r1xiba62nng651p4razxg1kw1910sl4grm7axm2g4q8s3i298"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/klauspost/compress"
- #:phases
- (modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'fix-permissions
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Provide write permissions on gzip files so that
- ;; reset-gzip-timestamps has sufficient permissions.
- (for-each make-file-writable
- (find-files (assoc-ref outputs "out") ".gz$")))))))
- (propagated-inputs
- (list go-github-com-golang-snappy))
+ (list
+ #:import-path "github.com/klauspost/compress"))
(home-page "https://github.com/klauspost/compress")
(synopsis "Go compression library")
(description "@code{compress} provides various compression algorithms.")