summaryrefslogtreecommitdiff
path: root/gnu/packages/gnucash.scm
diff options
context:
space:
mode:
authorTomas Volf <[email protected]>2025-01-03 15:24:27 +0100
committerLudovic Courtès <[email protected]>2025-01-19 23:09:55 +0100
commitaae6e533e03ce99ce3b38293e3754bca27b3defc (patch)
tree05551053f3b70939fe993b6d8c6445f954693300 /gnu/packages/gnucash.scm
parentf3315c3fa8a0b5a9eb74a0e1fc90e848a73fda92 (diff)
gnu: gnucash: Do not install gnc-fq-update.
This binary is used only for updating Finance::Quote from CPAN. That does not make sense on Guix, so do not install it. * gnu/packages/gnucash.scm (gnucash)[arguments]<#:phases>: Add delete-gnc-fq-update. Change-Id: I93cf6d67166cce5970d48eea42de0ee5a5a9a8f8 Signed-off-by: Ludovic Courtès <[email protected]>
Diffstat (limited to 'gnu/packages/gnucash.scm')
-rw-r--r--gnu/packages/gnucash.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 6df2b76505..7ac7cb0d8f 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -160,12 +160,16 @@
(map (lambda (l)
(assoc l (package-inputs this-package)))
'("perl-finance-quote")))))))))
- '("gnucash"
- "gnc-fq-update"))))
+ '("gnucash"))))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'install 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
+ (add-before 'glib-or-gtk-wrap 'delete-gnc-fq-update
+ (lambda _
+ ;; We are not updating Finance::Quote from CPAN. There is no
+ ;; reason to install this binary.
+ (delete-file (string-append #$output "/bin/gnc-fq-update")))))))
(native-inputs
(list gmp
`(,glib "bin") ;glib-compile-schemas, etc.