summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorZheng Junjie <[email protected]>2024-07-11 14:24:31 +0800
committerLudovic Courtès <[email protected]>2024-08-31 10:45:41 +0200
commit319ce074faf223c2944e155aece35f35da5a2369 (patch)
tree57c7acd9ffd32b80bb5b064ce68c525117bae2d5 /gnu/packages/gnome.scm
parentc2893113363f20f4255b0aadbc4dd094093f1c5f (diff)
gnu: openimageio: Fix build.
This fixes <https://issues.guix.gnu.org/72046>. * gnu/packages/graphics.scm (openimageio)[arguments]<#:phases>: Add fix-zlib-version phase. Change-Id: I7ea6e7b7da675bf11a85381cbe26c6992f2bd299
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2c16e33292..af46d352ee 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7257,6 +7257,10 @@ almost all of them.")
(replace 'check
(lambda* (#:key parallel-tests? tests? #:allow-other-keys)
(when tests?
+ (setenv "XDG_RUNTIME_DIR" (string-append (getcwd)
+ "/runtime-dir"))
+ (mkdir (getenv "XDG_RUNTIME_DIR"))
+ (chmod (getenv "XDG_RUNTIME_DIR") #o700)
(setenv "MESON_TESTTHREADS"
(if parallel-tests?
(number->string (parallel-job-count))