summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorAshvith Shetty <[email protected]>2025-02-24 21:50:58 +0530
committerLudovic Courtès <[email protected]>2025-02-24 23:33:51 +0100
commit1fb52d003da3a86e2edddd5e65577926dec127dd (patch)
treefe407a2f6164ae300a361b886a1f67314b0f2325 /gnu/packages/games.scm
parent536909ea67cd3cfe506326c6411a5c549bb88055 (diff)
gnu: gemrb: Update to 0.9.4.
* gnu/packages/games.scm (gemrb): Update to 0.9.4. * gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch: Delete file. * gnu/packages/patches/gemrb-remove-ifdef-and-externalize-path-setting-to-cmake.patch: New file. * gnu/local.mk (dist_patch_DATA): Remove old patch, register new patch. Change-Id: I7b82593246f425a14f6332a879aaf7ba8c6c5e31
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 36ca9d4b27..a261bb2d5f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12539,7 +12539,7 @@ virtual reality devices.")
(define-public gemrb
(package
(name "gemrb")
- (version "0.9.3")
+ (version "0.9.4")
(source
(origin
(method git-fetch)
@@ -12548,13 +12548,16 @@ virtual reality devices.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1wfmq4z2in18k4znshd7h1i496zlskbci49yp5d54mfxvyp534m5"))
- ;; Remove the patch in the next version, as commit d339c0d fixes this
+ (base32 "16pp9vw717pk9q8q3asxk4j64rmywbnpw91cr3qanwnmdi5p5gj4"))
+ ;; Remove the patch in the next version, as commit cca8e71 fixes this
(patches (search-patches
- "gemrb-add-path-suffixes-for-vlc-headers.patch"))))
+ "gemrb-remove-ifdef-and-externalize-path-setting-to-cmake.patch"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags `("-DUSE_TESTS=ON" "-DOPENGL_BACKEND=OpenGL")))
+ (list
+ #:cmake cmake-3.30
+ #:configure-flags
+ #~(list "-DUSE_TESTS=ON" "-DOPENGL_BACKEND=OpenGL")))
(native-inputs (list python-3.10 glibc-locales googletest))
(inputs (list freetype
libiconv