summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2024-09-27 09:24:18 +0900
committerMaxim Cournoyer <[email protected]>2024-09-27 09:39:18 +0900
commit64e1ae00e7e12cb07fe29efab631c6143acbe002 (patch)
tree24816cb811de0047e6c332f142018b0e346c3706 /gnu/packages/freedesktop.scm
parentce6f571fbe9f9426ebcc11c84c2a413aa22b877c (diff)
gnu: Add xdg-desktop-portal-next.
This is based on Dan's "xdg-desktop-portal: Update to 1.18.4." commit, now reverted. * gnu/packages/freedesktop.scm (xdg-desktop-portal-next): New variable. * gnu/packages/patches/xdg-desktop-portal-disable-portal-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: I7360d915bb0450f6772232c126fd0d4a4fec8997
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 2a78895a20..23ed788689 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2021 Robby Zambito <[email protected]>
;;; Copyright © 2021, 2022, 2023 Maxime Devos <[email protected]>
;;; Copyright © 2021, 2022 John Kehayias <[email protected]>
-;;; Copyright © 2021, 2021, 2022, 2023 Maxim Cournoyer <[email protected]>
+;;; Copyright © 2021-2024 Maxim Cournoyer <[email protected]>
;;; Copyright © 2022 Daniel Meißner <[email protected]>
;;; Copyright © 2022 Wamm K. D. <[email protected]>
;;; Copyright © 2022 Petr Hodina <[email protected]>
@@ -39,6 +39,7 @@
;;; Copyright © 2024 aurtzy <[email protected]>
;;; Copyright © 2024 Dariqq <[email protected]>
;;; Copyright © 2024 Wilko Meyer <[email protected]>
+;;; Copyright © 2024 dan <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -136,6 +137,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
+ #:use-module (gnu packages virtualization)
#:use-module (gnu packages w3m)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
@@ -3071,6 +3073,37 @@ The portal interfaces include APIs for file access, opening URIs, printing
and others.")
(license license:lgpl2.1+)))
+(define-public xdg-desktop-portal-next
+ (package
+ (inherit xdg-desktop-portal)
+ (version "1.18.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/flatpak/xdg-desktop-portal/releases/download/"
+ version "/xdg-desktop-portal-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0r8y8qmzcfj7b7brqcxr9lg8pavfds815ffvj0kqc378fhgaln5q"))
+ ;; Disable portal tests since they try to use fuse.
+ (patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
+ (build-system meson-build-system)
+ (arguments
+ (substitute-keyword-arguments (package-arguments xdg-desktop-portal)
+ ((#:configure-flags _ ''())
+ #~(list "-Dsystemd=disabled"))))
+ (native-inputs
+ (list pkg-config
+ `(,glib "bin")
+ gettext-minimal
+ python
+ python-dbusmock
+ python-pytest
+ python-pytest-xdist))
+ (inputs (modify-inputs (package-inputs xdg-desktop-portal)
+ (prepend bubblewrap)))))
+
(define-public xdg-desktop-portal-gtk
(package
(name "xdg-desktop-portal-gtk")