summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2022-06-27 19:23:48 +0200
committerMarius Bakke <[email protected]>2022-06-27 19:23:48 +0200
commit2a7648774f1bba5bb443c00b8ab1a2ab75b7416f (patch)
tree3e081532d1d4f83706b62b499f655ea3ed836e5b /gnu/packages/freedesktop.scm
parent43519035f954b3dc41ac50a9a877fd802b864fdb (diff)
parent0bd1c4fbbc8a438876d6efa4feb275de461a2484 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 36b792ccf0..adb2212610 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2022 Daniel Meißner <[email protected]>
;;; Copyright © 2022 Wamm K. D. <[email protected]>
;;; Copyright © 2022 Petr Hodina <[email protected]>
+;;; Copyright © 2022 muradm <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -704,6 +705,32 @@ the org.freedesktop.login1 interface over the system bus, allowing other parts
of a the system to know what users are logged in, and where.")
(license license:lgpl2.1+)))
+(define-public basu
+ (package
+ (name "basu")
+ (version "0.2.0")
+ (home-page "https://git.sr.ht/~emersion/basu")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h23n7wg18xc7xwldca18wi00iajyliixwicqyvv38qx831d8q18"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config python gperf))
+ (inputs
+ (list libcap))
+ (synopsis "The sd-bus library, extracted from systemd")
+ (description "Some projects rely on the sd-bus library for DBus support.
+However not all systems have systemd or elogind installed.
+This library provides just sd-bus (and the busctl utility).")
+ (license license:lgpl2.1+)))
+
(define-public localed
;; XXX: This package is extracted from systemd but we retain so little of it
;; that it would make more sense to maintain a fork of the bits we need.