summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-01-25 16:26:43 +0100
committerDanny Milosavljevic <[email protected]>2025-01-25 17:24:11 +0100
commitb5a91a6a039e781449d3d46b6385777dba99b1e9 (patch)
treef99222cfe44142356ba7c1f1ea93dacbf168cb2c /gnu/packages/finance.scm
parent1e6ee0f665d84d89f0f58fc933a896b5e72d852c (diff)
gnu: python-ledgerblue: Update to 0.1.54.
* gnu/packages/finance.scm (python-ledgerblue): Update to 0.1.54. [build-system]: Switch to pyproject-build-system. [native-inputs]: Add python-setuptools, python-wheel. [propagated-inputs]: Add python-bleak, python-pyelftools, python-pycryptodome, python-gnupg, python-nfcpy. Change-Id: If07cb78981340b395344a8bc93f62121a0b5a8b2
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index f535638c07..5aa4d9f60c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1051,21 +1051,28 @@ of Bitcoin BIP-0039.")
(define-public python-ledgerblue
(package
(name "python-ledgerblue")
- (version "0.1.44")
+ (version "0.1.54")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ledgerblue" version))
(sha256
(base32
- "0nbfa5i9ww7jsfc8cgy0r229pq2a1vj4xvn8mz0nxl7mx1wykqm4"))))
- (build-system python-build-system)
+ "0ghpvxgih1zarp788qi1xh5xmprv6yhaxglfbix4974i7r4pszqy"))))
+ (build-system pyproject-build-system)
(arguments
`(#:tests? #f)) ; no tests
+ (native-inputs
+ (list python-setuptools python-wheel))
(propagated-inputs
- (list python-ecpy
+ (list python-bleak
+ python-pyelftools
+ python-pycryptodome
+ python-ecpy
python-future
+ python-gnupg
python-hidapi
+ python-nfcpy
python-pillow
python-protobuf
python-pycryptodomex