summaryrefslogtreecommitdiff
path: root/gnu/packages/fabric-management.scm
diff options
context:
space:
mode:
authorLudovic Courtès <[email protected]>2024-12-01 17:46:43 +0100
committerLudovic Courtès <[email protected]>2024-12-01 17:46:43 +0100
commitc25fd8eeb136ee48e444b5cd91cee65426bb845f (patch)
treeb872d5acdea9e451f772258fc5e768b3005f97ef /gnu/packages/fabric-management.scm
parent4f6e9c7de16076f6444c6ffe55076ffb61be3f57 (diff)
Revert "gnu: ucx: Update to 1.17.0."
This reverts commit 7c36577cdec8185ea7df608eb9a68424e19ee9cb, which broke unit tests running in the chroot build environment. For instance, tests of ‘hdf5-parallel-openmpi’ would fail with: Testing ../../src/h5diff/ph5diff -c 1_vds.h5 2_vds.h5 *FAILED* ====Expected result (expect_sorted) differs from actual result (actual_sorted) *** expect_sorted 2024-12-01 16:41:03.795879595 +0000 --- actual_sorted 2024-12-01 16:41:03.791879542 +0000 *************** *** 1,3 **** --- 1,15 ---- Not comparable: </vds_dset> has rank 3, dimensions [5x18x8], max dimensions [18446744073709551615x18x8] Warning: </vds_dset> or </vds_dset> is a virtual dataset + [1733071262.437780] [localhost:33263:0] tcp_iface.c:893 UCX ERROR scandir(/sys/class/net) failed: No such file or directory + [1733071262.468994] [localhost:33247:0] tcp_iface.c:893 UCX ERROR scandir(/sys/class/net) failed: No such file or directory + [1733071262.479911] [localhost:33242:0] tcp_iface.c:893 UCX ERROR scandir(/sys/class/net) failed: No such file or directory Change-Id: I9c08d3c5375a2abd7d78344dfbef9b407828d1e0
Diffstat (limited to 'gnu/packages/fabric-management.scm')
-rw-r--r--gnu/packages/fabric-management.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/fabric-management.scm b/gnu/packages/fabric-management.scm
index 9b37314e65..7e539406db 100644
--- a/gnu/packages/fabric-management.scm
+++ b/gnu/packages/fabric-management.scm
@@ -185,22 +185,17 @@ testing InfiniBand networks.")
(define-public ucx
(package
(name "ucx")
- (version "1.17.0")
+ (version "1.15.0")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/openucx/ucx")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (patches (search-patches "ucx-tcp-iface-ioctl.patch"))
(sha256
(base32
- "09182kx60kq7iyjyz3mpcrgp1mm0lnpc0f4hd4hlw5yyabkxrpa1"))
- (snippet
- ;; As seen in commit b0a275a5492125a13020cd095fe9934e0b5e7c6a.
- #~(begin (use-modules (guix build utils))
- (substitute* "src/ucs/time/time.h"
- (("#include <limits.h>")
- "#include <limits.h>\n#include <math.h>"))))))
+ "1mk46vyfp8hsivk88s8gv0nf458jfs59fczpf66wwa3a9yp324jp"))))
(build-system gnu-build-system)
(arguments
(list
@@ -241,7 +236,6 @@ memory mechanisms for efficient intra-node communication.")
(home-page "https://www.openucx.org/")
(license bsd-3)
- ;; <ucm/bistro/bistro.h> lists only PowerPC64, AArch64, RISC-V
- ;; and x86_64 as supported.
- (supported-systems '("x86_64-linux" "aarch64-linux" "powerpc64le-linux"
- "riscv64-linux"))))
+ ;; <ucm/bistro/bistro.h> lists only PowerPC64, AArch64, and x86_64 as
+ ;; supported.
+ (supported-systems '("x86_64-linux" "aarch64-linux" "powerpc64le-linux"))))