summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <[email protected]>2024-12-07 20:41:23 +0100
committerJanneke Nieuwenhuizen <[email protected]>2024-12-08 01:01:43 +0100
commitc09cd73f5cc582ee234a875de48eed74f38b0e9d (patch)
treef9b0a5e0d41f8ea3bb0c088e29f903ddfe7b140d /gnu/packages/emacs.scm
parente613e45274c409ca72abbb712c0527f675608234 (diff)
gnu: guile-emacs: Update to 8f87cbc1dae6a9e77368afc5736df8c342e9153d.
* gnu/packages/patches/guile-emacs-build-fixes.patch: New file. * gnu/packages/patches/guile-emacs-fix-configure.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/emacs.scm (guile-emacs): Update to 8f87cbc1dae6a9e77368afc5736df8c342e9153d and use new patch. [arguments]: Allow parallel-build. Do not strip-binaries. Use recommended #:configure-flags and #:make-flags. Add stages "help-patch-progam-file-names" and "touch-lisp/finder-inf.el". No longer delete non-existent stage "strip-double-wrap". Delete stages "patch-compilation-driver", "set-libgccjit-path", "validate-comp-integrity", "restore-emacs-pdmp", "build-trampolines", and "install-site-start". [native-search-paths]: New field. Change-Id: I8153a55ef0061720ffd3c4833eff3ae6df3eccfc
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm53
1 files changed, 39 insertions, 14 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fcbb4fdfcb..e6dd17b510 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2017, 2019, 2020, 2023, 2024 Maxim Cournoyer <[email protected]>
;;; Copyright © 2017 Alex Vong <[email protected]>
;;; Copyright © 2017, 2018 Ricardo Wurmus <[email protected]>
-;;; Copyright © 2017, 2023 Janneke Nieuwenhuizen <[email protected]>
+;;; Copyright © 2017, 2023, 2024 Janneke Nieuwenhuizen <[email protected]>
;;; Copyright © 2018, 2023 Efraim Flashner <[email protected]>
;;; Copyright © 2018 Mathieu Othacehe <[email protected]>
;;; Copyright © 2018, 2019, 2021 Tobias Geerinckx-Rice <[email protected]>
@@ -629,7 +629,7 @@ editor (with wide ints)" )
(deprecated-package "emacs-next-tree-sitter" emacs-next))
(define-public guile-emacs
- (let ((commit "41120e0f595b16387eebfbf731fff70481de1b4b")
+ (let ((commit "8f87cbc1dae6a9e77368afc5736df8c342e9153d")
(revision "0"))
(package
(inherit emacs)
@@ -638,35 +638,60 @@ editor (with wide ints)" )
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://git.hcoop.net/git/bpt/emacs.git")
+ (url "https://codeberg.org/lyrra/guilemacs")
(commit commit)))
(file-name (git-file-name name version))
- (patches (search-patches "guile-emacs-fix-configure.patch"))
+ (patches (search-patches "guile-emacs-build-fixes.patch"))
(sha256
(base32
- "0lvcvsz0f4mawj04db35p1dvkffdqkz8pkhc0jzh9j9x2i63kcz6"))))
+ "1yhxy6d5i673y35i66d2x975zih3cw6p59ylsb8xk68wds6s7xrl"))))
(native-inputs
(modify-inputs (package-native-inputs emacs)
(prepend autoconf automake guile-for-guile-emacs)))
(arguments
- (substitute-keyword-arguments `(;; Build fails if we allow parallel build.
- #:parallel-build? #f
- ;; Tests aren't passing for now.
+ (substitute-keyword-arguments `(;; Tests aren't passing for now.
#:tests? #f
+ #:strip-binaries? #f
,@(package-arguments emacs))
((#:configure-flags flags ''())
- #~(delete "--with-cairo" #$flags))
+ #~`("CFLAGS=-Og -ggdb3"
+ "--with-native-compilation=no"
+ "--without-modules"
+ "--without-threads"
+ "--with-jpeg=no"
+ "--without-cairo"
+ "--without-tree-sitter"
+ ,@(fold delete #$flags '("--with-cairo"
+ "--with-modules"
+ "--with-native-compilation=aot"))))
+ ((#:make-flags flags #~'())
+ #~(list "V=1"))
((#:phases phases)
#~(modify-phases #$phases
(add-after 'unpack 'autogen
(lambda _
(invoke "sh" "autogen.sh")))
- ;; Build sometimes fails: deps/dispnew.d: No such file or directory
- (add-before 'build 'make-deps-dir
- (lambda _
- (invoke "mkdir" "-p" "src/deps")))
+ (delete 'patch-compilation-driver)
+ (delete 'set-libgccjit-path)
+ (delete 'validate-comp-integrity)
(delete 'restore-emacs-pdmp)
- (delete 'strip-double-wrap))))))))
+ (delete 'build-trampolines)
+ (delete 'install-site-start)
+ (add-after 'unpack 'help-patch-progam-file-names
+ (lambda _
+ (call-with-output-file "lisp/obsolete/terminal.el"
+ (lambda (port) (display port)))))
+ (add-after 'configure 'touch-lisp/finder-inf.el
+ (lambda _
+ (call-with-output-file "lisp/finder-inf.el"
+ (lambda (port) (display port)))))))))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "EMACSLOADPATH")
+ (files '("share/emacs/31.0.50/lisp")))
+ (search-path-specification
+ (variable "INFOPATH")
+ (files '("share/info"))))))))
(define-public m17n-db
(package