summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2024-12-08 18:30:54 +0100
committerLiliana Marie Prikler <[email protected]>2025-01-19 13:06:08 +0100
commit8f799ca8cee42a7be289022489d6ec08e329dac5 (patch)
tree13458fa441455021e30151faafafc61660403bee /gnu/packages/emacs.scm
parent71db233a7d2b5a25ece95853616f4c63a8158175 (diff)
gnu: emacs: Pin natively compiled packages.
* gnu/packages/patches/emacs-native-comp-pin-packages.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/emacs.scm (emacs)[source]: Use it here. [#:phases]: Remove ‘disable-native-compilation’. Fixes: Emacs native-comp collisions <https://issues.guix.gnu.org/67292>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c5b57211dd..a24242d5d7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -117,6 +117,7 @@
"emacs-fix-scheme-indent-function.patch"
"emacs-native-comp-driver-options.patch"
"emacs-native-comp-fix-filenames.patch"
+ "emacs-native-comp-pin-packages.patch"
"emacs-pgtk-super-key-fix.patch"))
(modules '((guix build utils)))
(snippet
@@ -233,16 +234,6 @@
(("\\(tramp-compat-process-running-p \"(.*)\"\\)" all process)
(format #f "(or ~a (tramp-compat-process-running-p ~s))"
all (string-append "." process "-real"))))))
- (add-after 'unpack 'disable-native-compilation
- (lambda _
- ;; Temporary workaround to prevent the behaviour discussed in
- ;; <https://issues.guix.gnu.org/72333>.
- ;; Please remove once the native-compilation for Emacs packages
- ;; is fully supported.
- (substitute* "lisp/transient.el"
- ((";; End:")
- ";; no-native-compile: t
-;; End:"))))
(add-before 'configure 'fix-/bin/pwd
(lambda _
;; Use `pwd', not `/bin/pwd'.