summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-14 11:50:28 +0000
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:53 +0100
commit5f17e6b4625c97754abae91fdfc9b88026292e71 (patch)
tree86c3bfb315192c58bd25e408672903f16f70d31b /gnu/packages/django.scm
parentba4619f5abe6a2bd1c6e9af06659b23a7a1b0624 (diff)
gnu: Add python-django-q2.
* gnu/packages/django.scm (python-django-q2): New variable. Change-Id: Ia96caca56b08903f4e8e49105baf4af430697cfc
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 95c4c18ba7..0e8590ade0 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2021 Maxim Cournoyer <[email protected]>
;;; Copyright © 2021 Luis Felipe López Acevedo <[email protected]>
;;; Copyright © 2022 Pradana Aumars <[email protected]>
+;;; Copyright © 2025 Sharlatan Hellseher <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1124,6 +1125,34 @@ settings.py and easily use them in your project.")
using Python multiprocessing.")
(license license:expat)))
+(define-public python-django-q2
+ (package
+ (name "python-django-q2")
+ (version "1.7.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "django_q2" version))
+ (sha256
+ (base32 "0zd1zpi5d3ky26i9rv0aii6kkb6gwvpypnwmsjbmpxiwawhv242j"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; FIXME: Tests require disque, Redis, MongoDB, Docker.
+ #:tests? #f))
+ (native-inputs
+ (list python-poetry-core))
+ (propagated-inputs
+ (list python-django
+ python-django-picklefield))
+ (home-page "https://django-q2.readthedocs.org")
+ (synopsis "Multiprocessing distributed task queue for Django")
+ (description
+ "This package provides a multiprocessing distributed task queue for
+Django. Django Q2 is a fork of Django Q with the new updated version of
+Django Q, dependencies updates, docs updates and several bug fixes.")
+ (license license:expat)))
+
(define-public python-django-sortedm2m
(package
(name "python-django-sortedm2m")