summaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorSarah Morgensen <[email protected]>2024-10-07 22:12:28 +0200
committerLudovic Courtès <[email protected]>2024-10-16 19:11:47 +0200
commit69899ca818e5606fc4694cbaf3385562b7394dab (patch)
tree8c30e834b58b1e70b8e0d3eef31e119326b05bd9 /gnu/packages/disk.scm
parent355795f2d81bbff27f1dbd1d2ab1e6f13daf7ee7 (diff)
gnu: libblockdev: Embed executable paths.
* gnu/packages/disk.scm (libblockdev)[arguments]<#:phases>: Add 'patch-plugin-paths' phase. Fixes: <https://bugs.gnu.org/33896>. Signed-off-by: Maxim Cournoyer <[email protected]> Change-Id: I96f9e2f03650b22ffef5a7fe091159450e4c5b67 Signed-off-by: Ludovic Courtès <[email protected]>
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 99b9e4d46d..b65df5186b 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2021 Mathieu Othacehe <[email protected]>
;;; Copyright © 2021 Brice Waegeneire <[email protected]>
;;; Copyright © 2021 Justin Veilleux <[email protected]>
+;;; Copyright © 2021 Sarah Morgensen <[email protected]>
;;; Copyright © 2014, 2022 Ludovic Courtès <[email protected]>
;;; Copyright © 2022 Maxim Cournoyer <[email protected]>
;;; Copyright © 2022 Disseminate Dissent <[email protected]>
@@ -29,6 +30,7 @@
;;; Copyright © 2023 Morgan Smith <[email protected]>
;;; Copyright © 2023 Zheng Junjie <[email protected]>
;;; Copyright © 2024 Sharlatan Hellseher <[email protected]>
+
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1195,7 +1197,13 @@ to create devices with respective mappings for the ATARAID sets discovered.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(substitute* "src/lib/blockdev.c"
- (("/etc/libblockdev/conf.d/" path) (string-append out path)))))))))
+ (("/etc/libblockdev/conf.d/" path) (string-append out path))))))
+ (add-after 'unpack 'patch-plugin-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (find-files "src/plugins" "\\.c$")
+ (("(gchar \\*arg.+\\{\")([^\"]+)" all start program)
+ ;; XXX: Use 'search-input-file' when available.
+ (string-append start (or (which program) program)))))))))
(native-inputs
(list gobject-introspection
pkg-config