summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-04 20:12:31 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:14:47 +0200
commitb22f76d4f7051a7100fe107d75bbab38e3745357 (patch)
tree823768e1fd95ab506aa491441cd4e0736c460433 /gnu/packages/crates-web.scm
parent46b1b202b0e915acbf85479a80d944999a7abe88 (diff)
gnu: rust-actix-web-3: Update to 3.3.3.
* gnu/packages/crates-web.scm (rust-actix-web-3): Update to 3.3.3. [arguments]: Don't skip the build. Skip the tests. Change-Id: I6a9970fe758e05704677f025dde8545874caa139
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 023f0ca40b..82818f698e 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -1498,16 +1498,16 @@ the Actix ecosystem.")
(package
(inherit rust-actix-web-4)
(name "rust-actix-web")
- (version "3.3.2")
+ (version "3.3.3")
(source
(origin
(method url-fetch)
(uri (crate-uri "actix-web" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "11kv8y1p9dw78lnhrw3rqavhmazmy7s0z8j14a3a1yp7fahx8hg6"))))
+ (base32 "0xz2wggpxqdi57caj1hx7ydwi4i0nk5529xs8gscm0gmdl94llxn"))))
(arguments
- `(#:skip-build? #t
+ `(#:tests? #f ; Test uses multiple undeclared crates.
#:cargo-inputs
(("rust-actix-codec" ,rust-actix-codec-0.3)
("rust-actix-http" ,rust-actix-http-2)