summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-29 22:27:27 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:21:20 +0200
commit8b19bf326edda4a85bbddaa64253993a9ba46ab1 (patch)
tree59e94eaf31b69ed31038560ca149353c5a1e7496 /gnu/packages/crates-web.scm
parent58b1176a53807f98325ea1cbbe9864e249143138 (diff)
gnu: Add rust-hoot-0.1.
* gnu/packages/crates-web.scm (rust-hoot-0.1): New variable. Change-Id: Iddf3b8a6addee583ae9bb5e4556e8e3154ec8f38
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index af1fc1527e..d1efb42a54 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -3816,6 +3816,27 @@ means it should be easily integrated into other software that also use those
libraries.")
(license (list license:expat license:asl2.0))))
+(define-public rust-hoot-0.1
+ (package
+ (name "rust-hoot")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hoot" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0mjfrn3yxhd2ll8kk5jhgasn8m2rbhb7va7s6dihin15afvf7spw"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-httparse" ,rust-httparse-1)
+ ("rust-log" ,rust-log-0.4))
+ #:cargo-development-inputs (("rust-memoffset" ,rust-memoffset-0.9))))
+ (home-page "https://github.com/algesten/hoot")
+ (synopsis "Http 1.1 library")
+ (description "This package provides an http 1.1 library.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-http-1
(package
(name "rust-http")