summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-01-21 08:38:36 +0200
committerEfraim Flashner <[email protected]>2025-01-21 08:50:27 +0200
commitf674fb6c9982283964eeaabc4a41797a2caeedb7 (patch)
treecb37990d5195043171e7a010350d30e870ae2258 /gnu/packages/crates-io.scm
parent2d5cce98f045205aa761be21fb7d19393ba3a043 (diff)
gnu: rust-jiter-0.5: Inherit from rust-jiter-0.7.
* gnu/packages/crates-io.scm (rust-jiter-0.5): Inherit from rust-jiter-0.7. Change-Id: Ib6b91c8173c0b8fd28a98f879af6c597e25c82ad
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index dab65ce2b7..cf219b0d11 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -36559,6 +36559,7 @@ heavily inspired by the Temporal project.")
(define-public rust-jiter-0.5
(package
+ (inherit rust-jiter-0.7)
(name "rust-jiter")
(version "0.5.0")
(source
@@ -36568,7 +36569,6 @@ heavily inspired by the Temporal project.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0ayj16d1rx5h5v7ihxgg198a9c190b6shsylzzfhxx9y2i4kbqh2"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-ahash" ,rust-ahash-0.8)
("rust-bitvec" ,rust-bitvec-1)
@@ -36584,12 +36584,7 @@ heavily inspired by the Temporal project.")
("rust-paste" ,rust-paste-1)
("rust-pyo3" ,rust-pyo3-0.22)
("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1))))
- (native-inputs (list python-minimal-wrapper)) ; For the tests.
- (home-page "https://github.com/pydantic/jiter/")
- (synopsis "Iterable JSON parser")
- (description "This package provides an iterable JSON parser.")
- (license license:expat)))
+ ("rust-serde-json" ,rust-serde-json-1))))))
(define-public rust-jiter-0.2
(package