summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-01-03 11:25:56 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:22:42 +0200
commit43f7a9774494ffa789d5dd3b0769b0d41ae9144a (patch)
tree50bf0c1d954d312d02f53c7731455ca3836502de /gnu/packages/crates-io.scm
parentb286a58aefa342ad9823042def655df93772a2c7 (diff)
gnu: Add rust-rlimit-0.9.
* gnu/packages/crates-io.scm (rust-rlimit-0.9): New variable. Change-Id: I3d691b1313cec7a869c171d66dddb3f7b2c6f208
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c2ff6356f1..027dbbaaee 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Ivan Petkov <[email protected]>
-;;; Copyright © 2019-2024 Efraim Flashner <[email protected]>
+;;; Copyright © 2019-2025 Efraim Flashner <[email protected]>
;;; Copyright © 2019-2024 Nicolas Goaziou <[email protected]>
;;; Copyright © 2019, 2024 Giacomo Leidi <[email protected]>
;;; Copyright © 2019–2021 Tobias Geerinckx-Rice <[email protected]>
@@ -63046,6 +63046,26 @@ this crate is here to save you the hassle of maintaining and testing
your own implementation.")
(license (list license:expat license:asl2.0))))
+(define-public rust-rlimit-0.9
+ (package
+ (name "rust-rlimit")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rlimit" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "13mb3ligflqb4h7m76pkyc8z5pswpc38fcl6qm1lvp2jls3rv8pq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-libc" ,rust-libc-0.2))
+ #:cargo-development-inputs (("rust-once-cell" ,rust-once-cell-1))))
+ (home-page "https://github.com/Nugine/rlimit/")
+ (synopsis "Resource limits")
+ (description "This package provides controls for resource limits.")
+ (license license:expat)))
+
(define-public rust-rlp-0.5
(package
(name "rust-rlp")