summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-01-24 10:47:59 +0200
committerEfraim Flashner <[email protected]>2024-02-20 13:58:30 +0200
commit040880cc04329f104fa6013669d20fa3a7a97d5f (patch)
treeb12720671fdfc3c21c3b2d5173b10d06b6534f83 /gnu/packages/crates-io.scm
parentdb219d6444727af61c9a1da05ad3c360ea97a7cd (diff)
gnu: rust-http: Move to (gnu packages crates-web).
* gnu/packages/crates-io.scm (rust-http-1, rust-http-0.2, rust-http-0.1, rust-http-auth-0.1, rust-http-body-0.4, rust-http-body-0.3, rust-http-body-0.1, rust-http-client-6, rust-http-range-header-0.3, rust-http-types-2): Move from here ... * gnu/packages/crates-web.scm: ... to here. Change-Id: I8689ccd065e50c109cb0e276bb267627fa69fd50
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm279
1 files changed, 0 insertions, 279 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a0175c4437..8b51d0cce9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -27827,285 +27827,6 @@ characters in HTML, decoding and unescaping HTML entities as well.")
and traversing, manipulating, and querying the document tree.")
(license license:expat)))
-(define-public rust-http-1
- (package
- (name "rust-http")
- (version "1.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "http" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1sllw565jn8r5w7h928nsfqq33x586pyasdfr7vid01scwwgsamk"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs (("rust-bytes" ,rust-bytes-1)
- ("rust-fnv" ,rust-fnv-1)
- ("rust-itoa" ,rust-itoa-1))
- #:cargo-development-inputs (("rust-doc-comment" ,rust-doc-comment-0.3)
- ("rust-indexmap" ,rust-indexmap-1.8)
- ("rust-quickcheck" ,rust-quickcheck-0.9)
- ("rust-rand" ,rust-rand-0.7)
- ("rust-seahash" ,rust-seahash-3)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1))))
- (home-page "https://github.com/hyperium/http")
- (synopsis "Set of types for representing HTTP requests and responses")
- (description "This package provides a set of types for representing HTTP
-requests and responses.")
- (license (list license:expat license:asl2.0))))
-
-(define-public rust-http-0.2
- (package
- (inherit rust-http-1)
- (name "rust-http")
- (version "0.2.11")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "http" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1fwz3mhh86h5kfnr5767jlx9agpdggclq7xsqx930fflzakb2iw9"))))
- (arguments
- `(#:cargo-inputs
- (("rust-bytes" ,rust-bytes-1)
- ("rust-fnv" ,rust-fnv-1)
- ("rust-itoa" ,rust-itoa-1))
- #:cargo-development-inputs
- (("rust-doc-comment" ,rust-doc-comment-0.3)
- ("rust-indexmap" ,rust-indexmap-1.8)
- ("rust-quickcheck" ,rust-quickcheck-0.9)
- ("rust-rand" ,rust-rand-0.7)
- ("rust-seahash" ,rust-seahash-3)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1))))))
-
-(define-public rust-http-0.1
- (package
- (inherit rust-http-0.2)
- (name "rust-http")
- (version "0.1.21")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "http" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1w21xnhd8f48zvbmm5njg2y1nb4p08ppn8r0cs2xi5d8wgnzbk6n"))))
- (arguments
- `(#:tests? #f ; doc tests fail
- #:cargo-inputs
- (("rust-bytes" ,rust-bytes-0.4)
- ("rust-fnv" ,rust-fnv-1)
- ("rust-itoa" ,rust-itoa-0.4))
- #:cargo-development-inputs
- (("rust-doc-comment" ,rust-doc-comment-0.3)
- ("rust-indexmap" ,rust-indexmap-1.8)
- ("rust-quickcheck" ,rust-quickcheck-0.6)
- ("rust-rand" ,rust-rand-0.4)
- ("rust-seahash" ,rust-seahash-3)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1))))))
-
-(define-public rust-http-auth-0.1
- (package
- (name "rust-http-auth")
- (version "0.1.8")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "http-auth" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1g6gpn2py0c4l45wp61k3zc45vg5l20zq39mxgxh56hzgb6wlc2l"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-base64" ,rust-base64-0.21)
- ("rust-digest" ,rust-digest-0.10)
- ("rust-hex" ,rust-hex-0.4)
- ("rust-http" ,rust-http-0.2)
- ("rust-log" ,rust-log-0.4)
- ("rust-md-5" ,rust-md-5-0.10)
- ("rust-memchr" ,rust-memchr-2)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-sha2" ,rust-sha2-0.10))
- #:cargo-development-inputs
- (("rust-pretty-assertions" ,rust-pretty-assertions-1)
- ("rust-reqwest" ,rust-reqwest-0.11))))
- (inputs
- (list openssl))
- (native-inputs
- (list pkg-config))
- (home-page "https://github.com/scottlamb/http-auth")
- (synopsis "HTTP authentication for rust")
- (description "This package provices HTTP authentication; it can parse
-challenge lists, respond to Basic and Digest challenges. It is likely to be
-extended with server support and additional auth schemes.")
- (license (list license:expat license:asl2.0))))
-
-(define-public rust-http-body-0.4
- (package
- (name "rust-http-body")
- (version "0.4.6")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "http-body" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1lmyjfk6bqk6k9gkn1dxq770sb78pqbqshga241hr5p995bb5skw"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-bytes" ,rust-bytes-1)
- ("rust-http" ,rust-http-0.2))))
- (home-page "https://github.com/hyperium/http-body")
- (synopsis "Asynchronous, streaming, HTTP request or response body")
- (description
- "This crate provides a trait representing an asynchronous, streaming,
-HTTP request or response body.")
- (license license:expat)))
-
-(define-public rust-http-body-0.3
- (package
- (inherit rust-http-body-0.4)
- (name "rust-http-body")
- (version "0.3.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "http-body" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "06qi0ni45lb92w3ml260c0bxbq5zd4snjmz0a9k69xq6021zzm8k"))))
- (arguments
- `(#:cargo-inputs
- (("rust-bytes" ,rust-bytes-0.5)
- ("rust-http" ,rust-http-0.2))))))
-
-(define-public rust-http-body-0.1
- (package
- (inherit rust-http-body-0.3)
- (name "rust-http-body")
- (version "0.1.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "http-body" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0b99404k4mw6a92hvyr0qwzkqv4f866ykg0x7913limjq5cwhhb7"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-bytes" ,rust-bytes-0.4)
- ("rust-futures" ,rust-futures-0.1)
- ("rust-http" ,rust-http-0.1)
- ("rust-tokio-buf" ,rust-tokio-buf-0.1))))))
-
-(define-public rust-http-client-6
- (package
- (name "rust-http-client")
- (version "6.3.4")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "http-client" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1i0mys38gsih9kkrdbfsmd8p9lnb2nd5wch76cpkjmqk8mm2mhcq"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-async-h1" ,rust-async-h1-2)
- ("rust-async-native-tls" ,rust-async-native-tls-0.3)
- ("rust-async-std" ,rust-async-std-1)
- ("rust-async-tls" ,rust-async-tls-0.10)
- ("rust-async-trait" ,rust-async-trait-0.1)
- ("rust-cfg-if" ,rust-cfg-if-1)
- ("rust-dashmap" ,rust-dashmap-4)
- ("rust-deadpool" ,rust-deadpool-0.7)
- ("rust-futures" ,rust-futures-0.3)
- ("rust-futures-util" ,rust-futures-util-0.3)
- ("rust-http-types" ,rust-http-types-2)
- ("rust-hyper" ,rust-hyper-0.13)
- ("rust-hyper-tls" ,rust-hyper-tls-0.4)
- ("rust-isahc" ,rust-isahc-0.9)
- ("rust-js-sys" ,rust-js-sys-0.3)
- ("rust-log" ,rust-log-0.4)
- ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
- ("rust-wasm-bindgen-futures" ,rust-wasm-bindgen-futures-0.4)
- ("rust-web-sys" ,rust-web-sys-0.3))))
- (home-page "https://github.com/http-rs/http-client")
- (synopsis "Types and traits for HTTP clients")
- (description "This package provides types and traits for HTTP clients.")
- (license (list license:expat license:asl2.0))))
-
-(define-public rust-http-range-header-0.3
- (package
- (name "rust-http-range-header")
- (version "0.3.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "http-range-header" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "13vm511vq3bhschkw2xi9nhxzkw53m55gn9vxg7qigfxc29spl5d"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-development-inputs
- (("rust-criterion" ,rust-criterion-0.5)
- ("rust-quickcheck" ,rust-quickcheck-1)
- ("rust-quickcheck-macros" ,rust-quickcheck-macros-1)
- ("rust-regex" ,rust-regex-1))))
- (home-page "https://github.com/MarcusGrass/parse-range-headers")
- (synopsis "No-dep range header parser")
- (description "This crate provides a no-dep range header parser.")
- (license license:expat)))
-
-(define-public rust-http-types-2
- (package
- (name "rust-http-types")
- (version "2.10.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "http-types" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0p7g2rzgzvnd419a5ddlyb2nz85z9bw7cdkqyl7467cx2fxkwq9j"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-anyhow" ,rust-anyhow-1)
- ("rust-async-channel" ,rust-async-channel-1)
- ("rust-async-std" ,rust-async-std-1)
- ("rust-base64" ,rust-base64-0.13)
- ("rust-cookie" ,rust-cookie-0.14)
- ("rust-futures-lite" ,rust-futures-lite-1)
- ("rust-http" ,rust-http-0.2)
- ("rust-infer" ,rust-infer-0.2)
- ("rust-pin-project-lite" ,rust-pin-project-lite-0.2)
- ("rust-rand" ,rust-rand-0.7)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-serde-qs" ,rust-serde-qs-0.7)
- ("rust-serde-urlencoded" ,rust-serde-urlencoded-0.7)
- ("rust-url" ,rust-url-2))))
- (home-page "https://github.com/http-rs/http-types")
- (synopsis "Common types for HTTP operations")
- (description
- "This package provides common types for HTTP operations.")
- (license (list license:expat license:asl2.0))))
-
(define-public rust-httparse-1
(package
(name "rust-httparse")