summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-04 10:35:10 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:14:30 +0200
commitb26a07b1d4f9f25886c8587984f0f685cc8a2604 (patch)
treed561bf6cc2c4bccd616c34d6f67c4fd1fec1173d /gnu/packages/crates-crypto.scm
parent882e9dfa104e1fec92efd5d4b1ce16f60ad02587 (diff)
gnu: rust-block-cipher-trait-0.6: Mark package as deprecated.
* gnu/packages/crates-crypto.scm (rust-block-cipher-trait-0.6): Rename to rust-block-cipher-trait-0.6.2-yanked. [source]: Add 'yanked' to the source file-name. (rust-block-cipher-trait-0.6): New deprecated package pointing to rust-block-cipher-trait-0.6.2-yanked. Change-Id: Ia1f8c55d14b3fcb77e4de723587d2f409a925fdb
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 8f08c92868..ac401c5ffb 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -875,15 +875,15 @@ based on Blake2s.")
ciphers.")
(license (list license:expat license:asl2.0))))
-(define-public rust-block-cipher-trait-0.6
+(define-public rust-block-cipher-trait-0.6.2-yanked
(package
(name "rust-block-cipher-trait")
- (version "0.6.2")
+ (version "0.6.2") ; This version was yanked!
(source
(origin
(method url-fetch)
(uri (crate-uri "block-cipher-trait" version))
- (file-name (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version "-yanked.tar.gz"))
(sha256
(base32 "0x273w6fwka0i48nrv428birdrs2jz6jdnmc0dhc1rq9pm4lv4hw"))))
(build-system cargo-build-system)
@@ -896,7 +896,13 @@ ciphers.")
(synopsis "Block cipher algorithms")
(description "This package provides a collection of block cipher
algorithms. This package is deprecated. Please use block-cipher instead.")
- (license (list license:expat license:asl2.0))))
+ (license (list license:expat license:asl2.0))
+ (properties '((crate-version-yanked? . #t)))))
+
+(define-public rust-block-cipher-trait-0.6
+ ;; There are no non-yanked versions of this semver.
+ (deprecated-package "rust-block-cipher-trait"
+ rust-block-cipher-trait-0.6.2-yanked))
(define-public rust-block-cipher-trait-0.4.2-yanked
(package