summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-04 10:28:35 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:14:30 +0200
commit86f440110c4ff6f3daf7cc286780549116a7c468 (patch)
tree80ac48742c0e55cbd29f986a5540a6f7d7ca6b3e /gnu/packages/crates-crypto.scm
parent3f9c4ad90a2758089cad77f86c76eee1976985ae (diff)
gnu: rust-aesni-0.6: Mark package as deprecated.
* gnu/packages/crates-crypto.scm (rust-aesni-0.6): Rename to rust-aesni-0.6.0-yanked. [source]: Add 'yanked' to the source file-name. (rust-aesni-0.6): New deprecated package pointing to rust-aesni-0.6.0-yanked. Change-Id: I623499ea673687be1de3247767ff4e0b373eb340
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index e934557cc2..8d14dbf0da 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -556,16 +556,16 @@ This package is deprecated and was replaced by the @code{aes} crate.")
(("rust-block-cipher" ,rust-block-cipher-0.7)
("rust-stream-cipher" ,rust-stream-cipher-0.4))))))
-(define-public rust-aesni-0.6
+(define-public rust-aesni-0.6.0-yanked
(package
(inherit rust-aesni-0.7)
(name "rust-aesni")
- (version "0.6.0")
+ (version "0.6.0") ; This version is yanked!
(source
(origin
(method url-fetch)
(uri (crate-uri "aesni" version))
- (file-name (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version "-yanked.tar.gz"))
(sha256
(base32 "007imgcfl82nilfpamj5dik83pkcmkzvbkxp384p7r3iz6sscw1g"))))
(arguments
@@ -573,7 +573,12 @@ This package is deprecated and was replaced by the @code{aes} crate.")
#:cargo-inputs
(("rust-block-cipher-trait" ,rust-block-cipher-trait-0.6)
("rust-opaque-debug" ,rust-opaque-debug-0.2)
- ("rust-stream-cipher" ,rust-stream-cipher-0.3))))))
+ ("rust-stream-cipher" ,rust-stream-cipher-0.3))))
+ (properties '((crate-version-yanked? . #t)))))
+
+(define-public rust-aesni-0.6
+ ;; There are no non-yanked versions of this semver.
+ (deprecated-package "rust-aesni" rust-aesni-0.6.0-yanked))
(define-public rust-argon2-0.5
(package