summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-03 20:35:03 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:27:51 +0000
commit27349661bb3c3d185a3231ccec1b1edd6b3fd6ea (patch)
treeb14e242445709e29c99db99326654f1cb57c4a3c /gnu/packages/cpp.scm
parentfbfff97ea9464eac3ed831570cf44c498e69144d (diff)
gnu: xtl: Improve package style.
* gnu/packages/cpp.scm (xtl): Shift order of fields. [source] <url>: Fix redirection issue, <https://github.com/QuantStack/xtl> permamently redirects to <https://github.com/xtensor-stack/xtl>. [arguments] <test-target>: Set to "xtest". <phases>: Use default 'check. [home-page]: Fix it. Change-Id: Ib3bc50b7a9e798be8888c2b1eac832d6a524bdae
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm39
1 files changed, 17 insertions, 22 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index cf3ccfbb55..bb48d139c2 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1061,30 +1061,25 @@ for C++17.")
(package
(name "xtl")
(version "0.7.5")
- (source (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/QuantStack/xtl")
- (commit version)))
- (sha256
- (base32
- "1llfy6pkzqx2va74h9xafjylyvw6839a843mqc05n6x6wll5bkam"))
- (file-name (git-file-name name version))))
- (native-inputs
- (list doctest googletest nlohmann-json))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xtensor-stack/xtl")
+ (commit version)))
+ (sha256
+ (base32 "1llfy6pkzqx2va74h9xafjylyvw6839a843mqc05n6x6wll5bkam"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
(arguments
(list
- #:configure-flags
- #~(list "-DBUILD_TESTS=ON")
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda _
- (with-directory-excursion "test"
- (invoke "./test_xtl")))))))
- (home-page "https://github.com/QuantStack/xtl")
- (build-system cmake-build-system)
+ #:configure-flags #~(list "-DBUILD_TESTS=ON")
+ #:test-target "xtest"))
+ (native-inputs
+ (list doctest
+ googletest
+ nlohmann-json))
+ (home-page "https://github.com/xtensor-stack/xtl")
(synopsis "C++ template library providing some basic tools")
(description "xtl is a C++ header-only template library providing basic
tools (containers, algorithms) used by other QuantStack packages.")