summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-20 14:23:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-21 23:42:12 +0000
commit8d4f5743d2bcbb31571dc0bdea03a4e3fbbfe10d (patch)
tree7f09634af425f868f0c0cb42be91e415d8228231 /gnu/packages/check.scm
parent8cbdfdf92efc284f0ddd4b1b79b2e79ff67b05d0 (diff)
gnu: gotestsum: Move to check.
* gnu/packages/golang.scm (gotestsum): Move from here ... * gnu/packages/check.scm: ... to here. Change-Id: I83f22e1f7dc1ad43340a02b60b75bf4e98b65474
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 47047de59e..f23258ca56 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
@@ -1124,6 +1125,53 @@ generation.")
similar to unit tests.")
(license license:asl2.0)))
+(define-public gotestsum
+ (package
+ (name "gotestsum")
+ (version "1.12.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gotestyourself/gotestsum")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fx92jh6ay4rk1ljbgp9b2m4fafqwy0a19q7lhdabgb1j8dvgxvs"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "gotest.tools/gotestsum"
+ #:test-flags
+ #~(list "-skip"
+ (string-join
+ (list "TestE2E_IgnoresWarnings"
+ "TestE2E_MaxFails_EndTestRun"
+ "TestScanTestOutput_TestTimeoutPanicRace/panic-race-2")
+ "|"))
+ ;; Run just unit test, integration tests from "testjson" require: run
+ ;; 'go test . -update' to automatically update
+ ;; testdata/summary/with-run-id to the new expected value.'
+ #:test-subdirs #~(list "cmd/..." "internal/...")))
+ (native-inputs
+ (list go-github-com-bitfield-gotestdox
+ go-github-com-dnephin-pflag
+ go-github-com-fatih-color
+ go-github-com-fsnotify-fsnotify
+ go-github-com-google-go-cmp
+ go-github-com-google-shlex
+ go-golang-org-x-sync
+ go-golang-org-x-sys
+ go-golang-org-x-term
+ go-golang-org-x-tools
+ go-gotest-tools-v3))
+ (synopsis "Go test runner with output optimized for humans")
+ (description "This package provides a @code{go test} runner with output
+optimized for humans, JUnit XML for CI integration, and a summary of the
+test results.")
+ (home-page "https://github.com/gotestyourself/gotestsum")
+ (license license:asl2.0)))
+
(define-public greatest
(package
(name "greatest")