summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2025-01-08 20:19:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:38 +0100
commit8979655ddf8d2903f4d6481bbbc519227d6ffc2c (patch)
tree747274ee6a0444f81dceb2a6dc5e5ff2550c814e /gnu/packages/bioinformatics.scm
parent72e25861ed622f29d645c169aa580ee715b69105 (diff)
gnu: python-liana-py: Update to 1.4.0.
* gnu/packages/bioinformatics.scm (python-liana-py): Update to 1.4.0. [arguments]: Adjust disabled tests. Change-Id: I9245285e2d043b5e7cbce5fb95a30982cd981597
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 20 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 05278882ec..7e21809cbd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2679,7 +2679,7 @@ servers supporting the protocol.")
(define-public python-liana-py
(package
(name "python-liana-py")
- (version "1.1.0")
+ (version "1.4.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2688,7 +2688,7 @@ servers supporting the protocol.")
(file-name (git-file-name name version))
(sha256
(base32
- "0f5al0v55haja91q9gd409v7q78mmp1wv9znsplsbjp6lfspjfnw"))))
+ "1kwbhfmsjhfc6m4kcp4zc2xgzg1qf16ywfkdamn868anwwrvjxzb"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -2696,20 +2696,36 @@ servers supporting the protocol.")
'(list "-k"
;; These tests require internet access.
(string-append "not test_generate_lr_resource"
+ " and not test_get_hcop"
" and not test_get_metalinks"
" and not test_get_metalinks_values"
" and not test_describe_metalinks"
" and not test_generate_nondefault_lr_resource"
+ " and not test_translate_resource"
;; Minor accuracy difference
" and not test_bivar_morans_perms"
+ ;; XXX "local_scores" array has wrong type.
+ ;; See https://github.com/saezlab/liana-py/issues/147
+ " and not test_morans_analytical"
+ " and not test_cosine_permutation"
+ " and not test_jaccard_pval_none_cats"
+ " and not test_large_adata"
+ ;; XXX ligand column differs: the left column
+ ;; contains duplicates.
+ " and not test_liana_pipe_not_defaults"
+ " and not test_liana_pipe_defaults"
;; XXX unclear failure: 'coo_matrix' object is not
;; subscriptable
" and not test_bivar_product"
- )
+ ;; XXX unclear failure: large difference in data
+ ;; frames.
+ " and not test_aggregate_res")
;; These need the optional squidpy, which we don't have yet.
"--ignore=liana/tests/test_misty.py"
;; These need the optional corneto.
- "--ignore=liana/tests/test_causalnet.py")
+ "--ignore=liana/tests/test_causalnet.py"
+ ;; Needs internet access.
+ "--ignore=liana/tests/test_orthology.py")
#:phases
'(modify-phases %standard-phases
(add-after 'unpack 'relax-requirements