summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-02-07 10:24:52 +0100
committerRicardo Wurmus <[email protected]>2025-02-07 10:28:43 +0100
commit84794fee72458979106e3f40e50c8d84f8ec9eb3 (patch)
tree05b245bd7630ec36fa5573fab65f6481a845ed33 /gnu/packages/bioinformatics.scm
parentabfd703c4e0ac84659736f53bf1bc4bc54e61a30 (diff)
gnu: r-bpcells: Update to 0.3.0.
* gnu/packages/bioinformatics.scm (r-bpcells): Update to 0.3.0. [arguments]: Remove phase 'do-not-tune; add phase 'chdir. [propagated-inputs]: Add r-lifecycle, r-readr, r-genomicranges, r-igraph, r-iranges, and r-matrixstats. [license]: Update to dual licensed ASL2.0 or Expat/MIT. Change-Id: I972c18e896372e3b44cd5c0ad2f669242568443f
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm102
1 files changed, 54 insertions, 48 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4670728c9a..9434c5e16c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -856,57 +856,63 @@ suite native in R.")
(license license:expat))))
(define-public r-bpcells
- (let ((commit "32ce67312185d3ed1046b4218dd3aaf1b35dcfda")
- (revision "1"))
- (package
- (name "r-bpcells")
- (version (git-version "0.1.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bnprks/BPCells/")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0im4sqvbii326acmd1hnimyzsllnbvnh9al3dp1nla6isgi7s6cg"))))
- (properties `((upstream-name . "BPCells")))
- (build-system r-build-system)
- (arguments
- (list
- #:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'do-not-tune
- (lambda _
- (substitute* "configure"
- (("\"-march=native\"") "\"\"")))))))
- (inputs (list hdf5 zlib))
- (propagated-inputs (list r-dplyr
- r-ggplot2
- r-ggrepel
- r-hexbin
- r-magrittr
- r-matrix
- r-patchwork
- r-rcolorbrewer
- r-rcpp
- r-rcppeigen
- r-rlang
- r-scales
- r-scattermore
- r-stringr
- r-tibble
- r-tidyr
- r-vctrs))
- (native-inputs (list pkg-config))
- (home-page "https://github.com/bnprks/BPCells/")
- (synopsis "Single cell counts matrices to PCA")
- (description
- "This is a package providing efficient operations for single cell
+ (package
+ (name "r-bpcells")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bnprks/BPCells")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12h1di45fg06nhsliii7v0h1z567pkpis1xm4ar1qr8ns1n8iljw"))))
+ (properties `((upstream-name . "BPCells")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "r"))))))
+ (propagated-inputs
+ (list r-dplyr
+ r-ggplot2
+ r-ggrepel
+ r-hexbin
+ r-lifecycle
+ r-magrittr
+ r-matrix
+ r-patchwork
+ r-rcolorbrewer
+ r-rcpp
+ r-rcppeigen
+ r-readr
+ r-rlang
+ r-scales
+ r-scattermore
+ r-stringr
+ r-tibble
+ r-tidyr
+ r-vctrs
+
+ ;; Suggested packages
+ r-genomicranges
+ r-igraph
+ r-iranges
+ r-matrixstats))
+ (inputs (list hdf5 zlib))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/bnprks/BPCells")
+ (synopsis "Single cell counts matrices to PCA")
+ (description
+ "This is a package providing efficient operations for single cell
ATAC-seq fragments and RNA counts matrices. It is interoperable with standard
file formats, and introduces efficient bit-packed formats that allow large
storage savings and increased read speeds.")
- (license license:gpl3))))
+ ;; Either license
+ (license (list license:asl2.0 license:expat))))
(define-public r-btools
(let ((commit "fa21d4ca01d37ea4d98b45582453f3bf95cbc2b5")