summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-17 11:28:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:22 +0100
commit6fa324e355495986d1aed90b6bbc3d87a3755baa (patch)
tree21e57870b7b645552d4cfe5f48bd563f9e58d916 /gnu/packages/bioinformatics.scm
parent89246206f0ffb984941f804fc4155bea1dac5940 (diff)
gnu: python-biom-format: Use pyproject-build-system.
* gnu/packages/bioinformatics.scm (python-biom-format)[build-system]: Use pyproject-build-system. [arguments]: Replace phase 'disable-broken-tests with #:test-flags; enable one test; add phase 'build-extensions. [native-inputs]: Remove python-nose. Change-Id: I8399d9b05bdb6da89d8056d536ab7e25dc22f9c2
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm48
1 files changed, 15 insertions, 33 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f12019372c..86bd84ce15 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3502,48 +3502,30 @@ use-case, we encourage users to compose functions to achieve their goals.")
;; Delete generated C files.
(snippet
'(for-each delete-file (find-files "." "\\.c")))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
+ #:test-flags
+ '(list "-k"
+ (string-append ;; Unclear why this one fails. There is no backtrace.
+ "not test_to_dataframe_is_sparse"
+ ;; These need skbio, but that neeeds biom-format.
+ " and not test_align_tree_intersect_obs"
+ " and not test_align_tree_intersect_tips"
+ " and not test_align_tree_sample"))
#:phases
'(modify-phases %standard-phases
(add-after 'unpack 'use-cython
(lambda _ (setenv "USE_CYTHON" "1")))
+ (add-before 'check 'build-extensions
+ (lambda _
+ ;; Cython extensions have to be built before running the tests.
+ (invoke "python" "setup.py" "build_ext" "--inplace")))
(add-after 'unpack 'pandas-compatibility
(lambda _
(substitute* "biom/tests/test_table.py"
(("import pandas.util.testing")
- "import pandas.testing"))))
- (add-after 'unpack 'disable-broken-tests
- (lambda _
- (substitute* "biom/tests/test_util.py"
- (("^(.+)def test_biom_open_hdf5_no_h5py" m indent)
- (string-append indent
- "@npt.dec.skipif(True, msg='Guix')\n"
- m)))
- (substitute* "biom/tests/test_table.py"
- (("^(.+)def test_from_hdf5_issue_731" m indent)
- (string-append indent
- "@npt.dec.skipif(True, msg='Guix')\n"
- m))
- ;; Unclear why this one fails. There is no backtrace.
- (("^(.+)def test_to_dataframe_is_sparse" m indent)
- (string-append indent
- "@npt.dec.skipif(True, msg='Guix')\n"
- m))
- ;; These need skbio, but that neeeds biom-format.
- (("^(.+)def test_align_tree_intersect_obs" m indent)
- (string-append indent
- "@npt.dec.skipif(True, msg='Guix')\n"
- m))
- (("^(.+)def test_align_tree_intersect_tips" m indent)
- (string-append indent
- "@npt.dec.skipif(True, msg='Guix')\n"
- m))
- (("^(.+)def test_align_tree_sample" m indent)
- (string-append indent
- "@npt.dec.skipif(True, msg='Guix')\n"
- m))))))))
+ "import pandas.testing")))))))
(propagated-inputs
(list python-anndata
python-click
@@ -3555,7 +3537,7 @@ use-case, we encourage users to compose functions to achieve their goals.")
;;python-scikit-bio ;mutually recursive dependency
python-scipy))
(native-inputs
- (list python-cython python-pytest python-pytest-cov python-nose))
+ (list python-cython python-pytest python-pytest-cov))
(home-page "https://www.biom-format.org")
(synopsis "Biological Observation Matrix (BIOM) format utilities")
(description