summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2024-11-27 16:28:26 +0100
committerRicardo Wurmus <[email protected]>2024-12-03 16:59:54 +0100
commita4a110c6c694e1a1061475334ac401acb8108f61 (patch)
tree1e4d88133877aee92efd416f592f08ed5cd21987 /gnu/packages/bioconductor.scm
parent014ee99b5f9f2475288f463e65ad1def61fb8f9e (diff)
gnu: r-monocle3: Update to 1.3.7.
* gnu/packages/bioconductor.scm (r-monocle3): Update to 1.3.7. [propagated-inputs]: Remove r-htmlwidgets, r-matrix-utils, r-pryr, r-rcppparallel, and r-reticulate; add r-biocparallel, r-delayedarray, r-digest, r-future, r-ggrastr, r-hdf5array, r-lme4, r-openssl, r-plyr, r-rcolorbrewer, r-rcppannoy, r-rcpphnsw, r-s4vectors, r-sf, and r-summarizedexperiment. [native-inputs]: Add r-testthat. [description]: Expand. [arguments]: Disable tests. Change-Id: I0331c5148dce5b282d25edf93e0ccc80397f78ec
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm150
1 files changed, 86 insertions, 64 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3408ebebac..e95713792c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -16218,70 +16218,92 @@ user-defined and/or data-driven sets of hypotheses.")
(license license:gpl3))))
(define-public r-monocle3
- (package
- (name "r-monocle3")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/cole-trapnell-lab/monocle3")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "16vpvlbms8fdvpfwzcig0rkg2mxnsq1h80d2l7q3953wm91qc9x4"))))
- (build-system r-build-system)
- (propagated-inputs
- (list r-assertthat
- r-batchelor
- r-biobase
- r-biocgenerics
- r-delayedmatrixstats
- r-dplyr
- r-ggplot2
- r-ggrepel
- r-grr
- r-htmlwidgets
- r-igraph
- r-irlba
- r-leidenbase
- r-limma
- r-lmtest
- r-mass
- r-matrix
- r-matrix-utils
- r-pbapply
- r-pbmcapply
- r-pheatmap
- r-plotly
- r-pryr
- r-proxy
- r-pscl
- r-purrr
- r-rann
- r-rcpp
- r-rcppparallel
- r-reshape2
- r-reticulate
- r-rhpcblasctl
- r-rsample
- r-rtsne
- r-shiny
- r-slam
- r-spdep
- r-speedglm
- r-stringr
- r-singlecellexperiment
- r-tibble
- r-tidyr
- r-uwot
- r-viridis))
- (home-page "https://github.com/cole-trapnell-lab/monocle3")
- (synopsis "Analysis toolkit for single-cell RNA-Seq data")
- (description
- "Monocle 3 is an analysis toolkit for single-cell RNA-Seq experiments.")
- (license license:expat)))
+ (let ((commit "98402ed0c10cac020524bebbb9300614a799f6d1")
+ (revision "1"))
+ (package
+ (name "r-monocle3")
+ (version (git-version "1.3.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cole-trapnell-lab/monocle3")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qs4qcdz9hcq966qcr7xvkpx3ri8g1n5psfwik09m7ngzpdd1r5q"))))
+ (properties `((upstream-name . "monocle3")))
+ (build-system r-build-system)
+ ;; FIXME Tests are apparently broken. 30 of them fail with accuracy
+ ;; errors.
+ (arguments (list #:tests? #false))
+ (propagated-inputs
+ (list r-assertthat
+ r-batchelor
+ r-biobase
+ r-biocgenerics
+ r-biocparallel
+ r-delayedarray
+ r-delayedmatrixstats
+ r-digest
+ r-dplyr
+ r-future
+ r-ggplot2
+ r-ggrastr
+ r-ggrepel
+ r-grr
+ r-hdf5array
+ r-igraph
+ r-irlba
+ r-leidenbase
+ r-limma
+ r-lme4
+ r-lmtest
+ r-mass
+ r-matrix
+ r-openssl
+ r-pbapply
+ r-pbmcapply
+ r-pheatmap
+ r-plotly
+ r-plyr
+ r-proxy
+ r-pscl
+ r-purrr
+ r-rann
+ r-rcolorbrewer
+ r-rcpp
+ r-rcppannoy
+ r-rcpphnsw
+ r-reshape2
+ r-rhpcblasctl
+ r-rsample
+ r-rtsne
+ r-s4vectors
+ r-sf
+ r-shiny
+ r-singlecellexperiment
+ r-slam
+ r-spdep
+ r-speedglm
+ r-stringr
+ r-summarizedexperiment
+ r-tibble
+ r-tidyr
+ r-uwot
+ r-viridis))
+ (native-inputs (list r-knitr r-testthat))
+ (home-page "https://github.com/cole-trapnell-lab/monocle3")
+ (synopsis "Analysis toolkit for single-cell RNA-Seq data")
+ (description
+ "Monocle 3 performs clustering, differential expression and trajectory
+analysis for single-cell expression experiments. It orders individual cells
+according to progress through a biological process, without knowing ahead of
+time which genes define progress through that process. Monocle 3 also
+performs differential expression analysis, clustering, visualization, and
+other useful tasks on single-cell expression data. It is designed to work
+with RNA-Seq data, but could be used with other types as well.")
+ (license license:expat))))
(define-public r-noiseq
(package