summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
authorVinicius Monego <[email protected]>2025-02-09 01:52:18 +0000
committerAndreas Enge <[email protected]>2025-02-09 10:36:22 +0100
commit9f5c891c6a93c0d9518e4651c44e11a71e08ef8f (patch)
treeaffffcd7421c59fffa052766d4b6b5b2778d7c82 /gnu/packages/algebra.scm
parent29515872744d9fcd755d2af7074c1cb6044e05a7 (diff)
gnu: Add normaliz.
* gnu/packages/algebra.scm (normaliz): New variable. Change-Id: I3e0936c598b0a5fdd88af9d22280137d42c45cc5 Signed-off-by: Andreas Enge <[email protected]>
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 9e2ad02fe7..e4841daa8d 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2020 Björn Höfling <[email protected]>
;;; Copyright © 2020 Jakub Kądziołka <[email protected]>
;;; Copyright © 2020 Vincent Legoll <[email protected]>
-;;; Copyright © 2020, 2021, 2023, 2024 Vinicius Monego <[email protected]>
+;;; Copyright © 2020, 2021, 2023, 2024, 2025 Vinicius Monego <[email protected]>
;;; Copyright © 2021 Lars-Dominik Braun <[email protected]>
;;; Copyright © 2022 Maxim Cournoyer <[email protected]>
;;; Copyright © 2023 Mehmet Tekman <[email protected]>
@@ -1017,6 +1017,32 @@ simple programming language but instead accepts a given language (C++) and
extends it by a set of algebraic capabilities.")
(license license:gpl2+)))
+(define-public normaliz
+ (package
+ (name "normaliz")
+ (version "3.10.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/normaliz/Normaliz")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1smla96wjyv5ygg77ps9np6bfzp2qynq8vd1msybabi4621cnrma"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool pkg-config))
+ ;; Flint is optional. TODO: Try to build with nauty and cocoalib support.
+ ;; The configure script fails to find nauty.h.
+ (inputs (list flint gmp))
+ (home-page "https://www.normaliz.uni-osnabrueck.de/")
+ (synopsis "Tool for discrete convex geometry")
+ (description "Normaliz is a tool for computations in affine monoids,
+vector configurations, rational polyhedra and rational cones. Normaliz now
+computes rational and algebraic polyhedra, i.e., polyhedra defined over real
+algebraic extensions of QQ.")
+ (license license:gpl3+)))
+
(define-public eigen
(package
(name "eigen")