summaryrefslogtreecommitdiff
path: root/gnu/packages/aidc.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2022-07-21 23:52:47 +0200
committerMarius Bakke <[email protected]>2022-07-21 23:52:47 +0200
commitabea091dbef2d44e6eb46bd2413bdf917e14d095 (patch)
tree28f6c61dbda0acb52678944b121b66a6f50a3709 /gnu/packages/aidc.scm
parent3b20467807c32aeac56bbbe22ffb8823f68e282b (diff)
parent3f171587bc6a47bb056f3e699e17e05f5832aea5 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/aidc.scm')
-rw-r--r--gnu/packages/aidc.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index 5482261a59..5e77ae3c5a 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014 John Darringon <[email protected]>
;;; Copyright © 2016, 2020, 2021 Efraim Flashner <[email protected]>
;;; Copyright © 2017 Hartmut Goebel <[email protected]>
-;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2018, 2019, 2022 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019 Guillaume Le Vaillant <[email protected]>
;;; Copyright © 2020 Leo Famulari <[email protected]>
;;;
@@ -23,6 +23,7 @@
(define-module (gnu packages aidc)
#:use-module (gnu packages)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -148,7 +149,7 @@ characters, and is highly robust.")
(define-public libdmtx
(package
(name "libdmtx")
- (version "0.7.5")
+ (version "0.7.7")
(source
(origin
(method git-fetch)
@@ -157,11 +158,11 @@ characters, and is highly robust.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0wk3fkxzf9ip75v8ia54v6ywx72ajp5s6777j4ay8barpbv869rj"))))
+ (base32 "0s95gplvb6x7gnl48yn7ywa9r15lfm8k2m60wm9i7w75ay4bq32i"))))
(build-system gnu-build-system)
(arguments
- ;; XXX Test suite is broken: https://github.com/dmtx/libdmtx/issues/22
- `(#:tests? #f))
+ (list #:configure-flags
+ #~(list "--disable-static")))
(native-inputs
(list autoconf automake libtool pkg-config))
(home-page "https://github.com/dmtx")