summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorNicolas Graves <[email protected]>2024-12-14 17:56:44 +0100
committerLudovic Courtès <[email protected]>2024-12-23 20:45:32 +0100
commitc2562c6415d56f0de8ab4da765ffb9d339dd5588 (patch)
tree5db907562c92d73c00d1572bb17c874c6933d4fc /gnu/packages/admin.scm
parent4b9b223bff65645b61666df48c12fd1a4f735b0f (diff)
gnu: Add pam-hooks.
* gnu/packages/admin.scm (pam-hooks): Add variable. Signed-off-by: Ludovic Courtès <[email protected]>
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 66d0bf30d8..e6948fda15 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3785,6 +3785,35 @@ shortcut syntax and completion options.")
(home-page "https://github.com/TrilbyWhite/interrobang")
(license license:gpl3+))))
+(define-public pam-hooks
+ (package
+ (name "pam-hooks")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://upsilon.cc/~zack/hacking/software/"
+ name "/" name "_" version ".tar.gz"))
+ (sha256
+ (base32 "102azxhvs53akkhgg2dkqg8m0jd6804fx8v7gq7pp03qm3m7bhqi"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags #~`("CC=gcc"
+ ,(string-append "DESTDIR=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))
+ ;; There is a test directory, but it's unclear how to run them.
+ #:tests? #f))
+ (inputs (list linux-pam))
+ (home-page "https://upsilon.cc/~zack/hacking/software/pam-hooks/")
+ (synopsis "Linux-PAM module for login/logout hooks")
+ (description "@code{pam-hooks} is a tiny PAM module enabling the
+execution of hook scripts when a PAM session is opened or closed. The
+typical use case is the need of doing some per-user set-up when a user
+logs via a PAM-aware login mechanism and/or the need of doing some
+per-user clean-up when the user logs out.")
+ (license license:gpl3+)))
+
(define-public pam-krb5
(package
(name "pam-krb5")