summaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-02 20:38:20 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:36 +0000
commit5d01c235487137bef3f353bebd2ee43a112aabba (patch)
tree313e13ce42b92206899641b2975c66960c2175a7 /gnu/packages/admin.scm
parentc6a575bade92c50b255a6ca51d2ea1a185ca91de (diff)
gnu: doctl: Update to 1.120.0.
* gnu/packages/admin.scm (doctl): Update to 1.120.0. [source] <snippet>: Delete some bundled packages. [native-inputs]: Add go-golang-org-x-crypto, go-golang-org-x-mod, go-golang-org-x-net, go-golang-org-x-oauth2, go-golang-org-x-sync, go-golang-org-x-sys, go-golang-org-x-term, go-golang-org-x-text, go-golang-org-x-time, and go-golang-org-x-tools. Change-Id: I7b64ebb7023f8e0fbf445a085de42aa94934e96a
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6f688fd366..5b0473dafd 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -6402,7 +6402,7 @@ file or files to several hosts.")
(define-public doctl
(package
(name "doctl")
- (version "1.94.0")
+ (version "1.120.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6411,7 +6411,12 @@ file or files to several hosts.")
(file-name (git-file-name name version))
(sha256
(base32
- "0a221n0x7qrq0dbhhf1saya2g7jyy1798k3rhy9nzyvqzc4vnd0x"))))
+ "12fgymgiv6894ghar7ljg69hb7mi18pa2a74sp7fyymqvyhiv6z9"))
+ (snippet
+ ;; TODO: Unbundle more.
+ #~(begin (use-modules (guix build utils))
+ (for-each delete-file-recursively
+ (list "vendor/golang.org"))))))
(build-system go-build-system)
(arguments
(list #:import-path "github.com/digitalocean/doctl/cmd/doctl"
@@ -6441,6 +6446,17 @@ file or files to several hosts.")
"/etc/fish/completions/doctl.fish")
(install-completion "zsh"
"/etc/zsh/site-functions/_doctl"))))))
+ (native-inputs
+ (list go-golang-org-x-crypto
+ go-golang-org-x-mod
+ go-golang-org-x-net
+ go-golang-org-x-oauth2
+ go-golang-org-x-sync
+ go-golang-org-x-sys
+ go-golang-org-x-term
+ go-golang-org-x-text
+ go-golang-org-x-time
+ go-golang-org-x-tools))
(home-page "https://github.com/digitalocean/doctl")
(synopsis "Command line client for DigitalOcean")
(description