summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <[email protected]>2024-12-24 01:11:09 +0800
committerZheng Junjie <[email protected]>2025-01-25 01:05:26 +0800
commitfffecf715bf0f0f7e1f06cc9add9f0cc70a986db (patch)
treebbb05479ba3f25cbe92b03693fd840c60a36b4c6
parent40f5d733958848731f91fa2f93a980a373bac1d5 (diff)
gnu: %glibc-stripped: Fix cross-compiling to loongarch64.
gnu/packages/make-bootstrap.scm (%glibc-stripped)[inputs]: When target loongarch64, Use linux-libre-headers-5.19.17. Change-Id: I4b2b9168aa3716445d1b88b4db3dcf4ad038a45d
-rw-r--r--gnu/packages/make-bootstrap.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 59c117f226..864d84d89e 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -475,11 +475,13 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
glibc)))))
(inputs
`(("kernel-headers"
- ,(if (or (and (%current-target-system)
+ ,(cond ((or (and (%current-target-system)
(target-hurd? (%current-target-system)))
(string-suffix? "-hurd" (%current-system)))
- gnumach-headers
- linux-libre-headers))))
+ gnumach-headers)
+ ;; linux 5.19 include loongarch support.
+ ((target-loongarch64?) linux-libre-headers-5.19.17)
+ (else linux-libre-headers)))))
(propagated-inputs '())
;; Only one output.