summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-12-24 09:51:39 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2025-03-02 20:31:39 +0100
commitf65d0b3a1d6e02b4546f6615d97a692a55e76ac8 (patch)
treed4550bbfb8d283d73aa261d9eb5edc970a447950
parent2922224e4fd1d0d6f2445c9d4912789d70bb58bb (diff)
gnu: gdk-pixbuf: Build with other loaders enabled.
GTK+ 3 currently fails to build, as it requires the XPM loader be enabled. See also <https://gitlab.gnome.org/GNOME/gtk/-/issues/7143>. * gnu/packages/gtk.scm (gdk-pixbuf)[#:configure-flags]: Add “-Dothers=enabled”.
-rw-r--r--gnu/packages/gtk.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 933d1e6a7f..75288aaa9b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -736,7 +736,10 @@ highlighting and other features typical of a source code editor.")
#:configure-flags '("-Dinstalled_tests=false"
,@(if (%current-target-system)
'()
- '("-Dgtk_doc=true")))
+ '("-Dgtk_doc=true"))
+ ;; GTK+ 3 needs the XPM loader, see
+ ;; <https://gitlab.gnome.org/GNOME/gtk/-/issues/7143>.
+ "-Dothers=enabled")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'disable-failing-tests