summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2024-12-01 10:12:32 +0100
committerRicardo Wurmus <[email protected]>2024-12-01 10:26:38 +0100
commitf228b0173807de86394623b1bdc0340caff9a35b (patch)
treedee81f7d475598fac992ae3b00ef0ca53eceaf65
parent5725688923c6bfea89e6a8aed91e88bc9ef6cf49 (diff)
gnu: Add r-colorsgen.
* gnu/packages/cran.scm (r-colorsgen): New variable. Change-Id: I1acb2b0dd2661a5abdb59451522da6dffa85f470
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c5ac9fbb2e..494624e8b0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -565,6 +565,26 @@ Shiny applications.")
(license (list license:gpl3
license:isc)))) ;for bundled d3js
+(define-public r-colorsgen
+ (package
+ (name "r-colorsgen")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "colorsGen" version))
+ (sha256
+ (base32 "0w4qkl4fw7pjfcd2z3nhpkxh8kv3bbq19bi2cg0ivfr83kxa44fj"))))
+ (properties `((upstream-name . "colorsGen")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-colorspace))
+ (home-page "https://github.com/stla/colorsGen")
+ (synopsis "Generation of random colors")
+ (description
+ "This package lets you generate random colors, possibly with a given hue
+or a given luminosity.")
+ (license license:cc0)))
+
(define-public r-consort
(package
(name "r-consort")