summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-01-26 19:58:55 +0200
committerEfraim Flashner <[email protected]>2025-01-26 20:00:06 +0200
commitee920138d56837576ec4ccda2b5f38f51484ab2f (patch)
tree1b51c281f87769630913183108da24de85587e1e
parentdc7f2cd9d8acc8e977f7e5c2b6ed3bac8ae0cbb5 (diff)
gnu: vulkan-loader: Don't run the tests when cross-compiling.
* gnu/packages/vulkan.scm (vulkan-loader)[arguments]: Adjust the tests flag to run the tests when not cross-compiling. Change-Id: I1a31132ae38874adde598bc19e0ffe18896dd589
-rw-r--r--gnu/packages/vulkan.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index dd5b51c7fe..241dff73ac 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2018, 2019 Rutger Helling <[email protected]>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <[email protected]>
-;;; Copyright © 2018, 2023, 2024 Efraim Flashner <[email protected]>
+;;; Copyright © 2018, 2023-2025 Efraim Flashner <[email protected]>
;;; Copyright © 2020, 2023 Marius Bakke <[email protected]>
;;; Copyright © 2021 Mathieu Othacehe <[email protected]>
;;; Copyright © 2022 Kaelyn Takata <[email protected]>
@@ -363,7 +363,7 @@ Enhanced Subpixel Morphological Anti-Aliasing
(list
;; As many as 23 tests are expected to fail per architecture.
;; Limit the tests to those architectures tested upstream.
- #:tests? (and (%current-system)
+ #:tests? (and (not (%current-target-system))
(target-x86?))
#:configure-flags
#~(list (string-append "-DVULKAN_HEADERS_INSTALL_DIR="